adb: new package "Android Debug Bridge"
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
This commit is contained in:
parent
c8043137bb
commit
363c3e68ac
2 changed files with 97 additions and 0 deletions
52
package/utils/adb/Makefile
Normal file
52
package/utils/adb/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
#Based on adb package from AUR https://aur.archlinux.org/packages/adb/ , reused Makefile
|
||||
|
||||
PKG_NAME:=adb
|
||||
PKG_VERSION:=android.5.0.2_r1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://android.googlesource.com/platform/system/core
|
||||
PKG_SOURCE_VERSION:=6fe92d1a3fb17545d82d020a3c995f32e6b71f9d
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
||||
PKG_MAINTAINER:=Henryk Heisig <hyniu@o2.pl>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
ifeq ($(CONFIG_BIG_ENDIAN),y)
|
||||
TARGET_CFLAGS+= -DHAVE_BIG_ENDIAN=1
|
||||
endif
|
||||
TARGET_CFLAGS+= -D_GNU_SOURCE
|
||||
|
||||
define Package/adb
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Android Debug Bridge CLI tool
|
||||
URL:=http://tools.android.com/
|
||||
DEPENDS:=+zlib +libopenssl +libpthread
|
||||
endef
|
||||
|
||||
define Package/bridge/description
|
||||
Android Debug Bridge (adb) is a versatile command line tool that lets you communicate with an emulator instance or connected Android-powered device.
|
||||
endef
|
||||
|
||||
# Nothing just to be sure
|
||||
#define Build/Configure
|
||||
#endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/adb/ \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
TARGET=Linux \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)"
|
||||
endef
|
||||
|
||||
define Package/adb/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/adb/adb $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,adb))
|
45
package/utils/adb/patches/001-create_Makefile.patch
Normal file
45
package/utils/adb/patches/001-create_Makefile.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- /dev/null
|
||||
+++ b/adb/Makefile 2016-10-19 15:28:03.421194137 +0200
|
||||
@@ -0,0 +1,42 @@
|
||||
+SRCS+= adb.c
|
||||
+SRCS+= adb_auth_host.c
|
||||
+SRCS+= adb_client.c
|
||||
+SRCS+= commandline.c
|
||||
+SRCS+= console.c
|
||||
+SRCS+= fdevent.c
|
||||
+SRCS+= file_sync_client.c
|
||||
+SRCS+= get_my_path_linux.c
|
||||
+SRCS+= services.c
|
||||
+SRCS+= sockets.c
|
||||
+SRCS+= transport.c
|
||||
+SRCS+= transport_local.c
|
||||
+SRCS+= transport_usb.c
|
||||
+SRCS+= usb_linux.c
|
||||
+
|
||||
+VPATH+= ../libcutils
|
||||
+SRCS+= load_file.c
|
||||
+SRCS+= socket_inaddr_any_server.c
|
||||
+SRCS+= socket_local_client.c
|
||||
+SRCS+= socket_local_server.c
|
||||
+SRCS+= socket_loopback_client.c
|
||||
+SRCS+= socket_loopback_server.c
|
||||
+SRCS+= socket_network_client.c
|
||||
+
|
||||
+VPATH+= ../libzipfile
|
||||
+SRCS+= centraldir.c
|
||||
+SRCS+= zipfile.c
|
||||
+
|
||||
+CPPFLAGS+= -DADB_HOST=1
|
||||
+CPPFLAGS+= -DHAVE_FORKEXEC=1
|
||||
+CPPFLAGS+= -I.
|
||||
+CPPFLAGS+= -I../include
|
||||
+CPPFLAGS+= -D_FILE_OFFSET_BITS=64
|
||||
+
|
||||
+LIBS+= -lcrypto -lpthread -lz
|
||||
+
|
||||
+OBJS= $(SRCS:.c=.o)
|
||||
+
|
||||
+all: adb
|
||||
+
|
||||
+adb: $(OBJS)
|
||||
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LIBS)
|
Loading…
Reference in a new issue