d165f1f3bc
The driver is used for boards outside the lantiq target as well. Move it to generic to make it available for more targets. The phy driver is included in kernel 4.8 as INTEL_XWAY_PHY. Signed-off-by: Mathias Kresin <dev@kresin.me>
26 lines
859 B
Diff
26 lines
859 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -175,6 +175,13 @@ config LANTIQ_PHY
|
|
---help---
|
|
Supports the 11G and 22F PHYs.
|
|
|
|
+config ADM6996_PHY
|
|
+ tristate "Driver for ADM6996 switches"
|
|
+ select SWCONFIG
|
|
+ ---help---
|
|
+ Currently supports the ADM6996FC and ADM6996M switches.
|
|
+ Support for FC is very limited.
|
|
+
|
|
config FIXED_PHY
|
|
tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -22,6 +22,7 @@ obj-$(CONFIG_BCM7XXX_PHY) += bcm7xxx.o
|
|
obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
|
|
obj-$(CONFIG_BCM_CYGNUS_PHY) += bcm-cygnus.o
|
|
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
|
+obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
|