kernel: move Lantiq PEF7061/7071/7072 phy driver to generic
The driver is used for boards outside the lantiq target as well. Move it to generic to make it available for more targets. The phy driver is included in kernel 4.8 as INTEL_XWAY_PHY. Signed-off-by: Mathias Kresin <dev@kresin.me>
This commit is contained in:
parent
7e12863252
commit
d165f1f3bc
15 changed files with 19 additions and 19 deletions
|
@ -1883,6 +1883,7 @@ CONFIG_KUSER_HELPERS=y
|
|||
# CONFIG_L2TP_V3 is not set
|
||||
# CONFIG_LANMEDIA is not set
|
||||
# CONFIG_LANTIQ is not set
|
||||
# CONFIG_LANTIQ_PHY is not set
|
||||
# CONFIG_LAPB is not set
|
||||
# CONFIG_LASAT is not set
|
||||
# CONFIG_LATENCYTOP is not set
|
||||
|
|
|
@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
|
||||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -202,6 +202,11 @@ config RTL8306_PHY
|
||||
tristate "Driver for Realtek RTL8306S switches"
|
||||
select SWCONFIG
|
||||
@@ -156,6 +156,11 @@ config MICROCHIP_PHY
|
||||
help
|
||||
Supports the LAN88XX PHYs.
|
||||
|
||||
+config LANTIQ_PHY
|
||||
+ tristate "Driver for Lantiq PHYs"
|
||||
|
@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
depends on PHYLIB
|
||||
--- a/drivers/net/phy/Makefile
|
||||
+++ b/drivers/net/phy/Makefile
|
||||
@@ -46,6 +46,7 @@ obj-$(CONFIG_DP83848_PHY) += dp83848.o
|
||||
@@ -30,6 +30,7 @@ obj-$(CONFIG_DP83848_PHY) += dp83848.o
|
||||
obj-$(CONFIG_DP83867_PHY) += dp83867.o
|
||||
obj-$(CONFIG_STE10XP) += ste10Xp.o
|
||||
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
@ -1,8 +1,8 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -170,6 +170,13 @@ config MICROCHIP_PHY
|
||||
help
|
||||
Supports the LAN88XX PHYs.
|
||||
@@ -175,6 +175,13 @@ config LANTIQ_PHY
|
||||
---help---
|
||||
Supports the 11G and 22F PHYs.
|
||||
|
||||
+config ADM6996_PHY
|
||||
+ tristate "Driver for ADM6996 switches"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -177,6 +177,10 @@ config ADM6996_PHY
|
||||
@@ -182,6 +182,10 @@ config ADM6996_PHY
|
||||
Currently supports the ADM6996FC and ADM6996M switches.
|
||||
Support for FC is very limited.
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -181,6 +181,10 @@ config MVSWITCH_PHY
|
||||
@@ -186,6 +186,10 @@ config MVSWITCH_PHY
|
||||
tristate "Driver for Marvell 88E6060 switches"
|
||||
select ETHERNET_PACKET_MANGLE
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -185,6 +185,11 @@ config IP17XX_PHY
|
||||
@@ -190,6 +190,11 @@ config IP17XX_PHY
|
||||
tristate "Driver for IC+ IP17xx switches"
|
||||
select SWCONFIG
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -190,6 +190,10 @@ config AR8216_PHY
|
||||
@@ -195,6 +195,10 @@ config AR8216_PHY
|
||||
select ETHERNET_PACKET_MANGLE
|
||||
select SWCONFIG
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -294,6 +294,30 @@ config MDIO_BCM_IPROC
|
||||
@@ -299,6 +299,30 @@ config MDIO_BCM_IPROC
|
||||
This module provides a driver for the MDIO busses found in the
|
||||
Broadcom iProc SoC's.
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -316,6 +316,10 @@ config RTL8366RB_PHY
|
||||
@@ -321,6 +321,10 @@ config RTL8366RB_PHY
|
||||
tristate "Driver for the Realtek RTL8366RB switch"
|
||||
select SWCONFIG
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -320,6 +320,10 @@ config RTL8367_PHY
|
||||
@@ -325,6 +325,10 @@ config RTL8367_PHY
|
||||
tristate "Driver for the Realtek RTL8367R/M switches"
|
||||
select SWCONFIG
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -331,3 +331,8 @@ endif # PHYLIB
|
||||
@@ -336,3 +336,8 @@ endif # PHYLIB
|
||||
config MICREL_KS8995MA
|
||||
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
|
||||
depends on SPI
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -326,6 +326,8 @@ config RTL8367B_PHY
|
||||
@@ -331,6 +331,8 @@ config RTL8367B_PHY
|
||||
|
||||
endif # RTL8366_SMI
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -190,6 +190,10 @@ config AR8216_PHY
|
||||
@@ -195,6 +195,10 @@ config AR8216_PHY
|
||||
select ETHERNET_PACKET_MANGLE
|
||||
select SWCONFIG
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -181,6 +181,10 @@ config MVSWITCH_PHY
|
||||
@@ -186,6 +186,10 @@ config MVSWITCH_PHY
|
||||
tristate "Driver for Marvell 88E6060 switches"
|
||||
select ETHERNET_PACKET_MANGLE
|
||||
|
||||
|
|
|
@ -110,7 +110,6 @@ CONFIG_IRQ_WORK=y
|
|||
CONFIG_LANTIQ=y
|
||||
CONFIG_LANTIQ_DT_NONE=y
|
||||
CONFIG_LANTIQ_ETOP=y
|
||||
# CONFIG_LANTIQ_PHY is not set
|
||||
CONFIG_LANTIQ_WDT=y
|
||||
# CONFIG_LANTIQ_XRX200 is not set
|
||||
CONFIG_LEDS_GPIO=y
|
||||
|
|
Loading…
Reference in a new issue