d165f1f3bc
The driver is used for boards outside the lantiq target as well. Move it to generic to make it available for more targets. The phy driver is included in kernel 4.8 as INTEL_XWAY_PHY. Signed-off-by: Mathias Kresin <dev@kresin.me>
23 lines
731 B
Diff
23 lines
731 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -325,6 +325,10 @@ config RTL8367_PHY
|
|
tristate "Driver for the Realtek RTL8367R/M switches"
|
|
select SWCONFIG
|
|
|
|
+config RTL8367B_PHY
|
|
+ tristate "Driver fot the Realtek RTL8367R-VB switch"
|
|
+ select SWCONFIG
|
|
+
|
|
endif # RTL8366_SMI
|
|
|
|
endif # PHYLIB
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -32,6 +32,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
|
|
obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
|
|
obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
|
|
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
|
|
+obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|