openwrtv3/target/linux/lantiq
Kevin Darbyshire-Bryant 0276e1f760 lantiq: atm: fix ifx_atm driver integration
When upstream kernel introduced commit c55fa3cccbc2c672e7f118be8f7484e53a8e9e77
we incorrectly updated our hack integration patch that updates atm/common.c

+++ b/net/atm/common.c
@@ -62,10 +62,16 @@ static void vcc_remove_socket(struct soc
        write_unlock_irq(&vcc_sklist_lock);
 }

+struct sk_buff* (*ifx_atm_alloc_tx)(struct atm_vcc *, unsigned int) = NULL;
+EXPORT_SYMBOL(ifx_atm_alloc_tx);
+
 static bool vcc_tx_ready(struct atm_vcc *vcc, unsigned int size)
 {
        struct sock *sk = sk_atm(vcc);

+       if (ifx_atm_alloc_tx != NULL)
+               return ifx_atm_alloc_tx(vcc, size)

The correct solution is to drop our ifx_atm_alloc_tx replacement hack
entirely and let the kernel do its thing.

In reality neither pppoatm or BR2684 interfaces actually hit this code,
so the incorrect integration would only be noticed with direct socket
calls which we are unaware of a use-case.

This is not the solution to pppoatm vc-mux failing to work which started
the whole investigation, but let's fix it up anyway.

With sincerest thanks to David Woodhouse <dwmw2@infradead.org> &
Mathias Kresin <dev@kresin.me>.

Tested-on: lantiq, BT HomeHub 5a

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
2018-06-18 15:26:41 +02:00
..
ase lantiq: switch to kernel 4.14 2018-05-17 07:40:19 +02:00
base-files lantiq: complete AVM FRITZ!Box 3370 support 2018-05-17 07:40:19 +02:00
falcon lantiq: switch to kernel 4.14 2018-05-17 07:40:19 +02:00
files/firmware/lantiq lantiq: rename gphy firmware 2018-02-20 19:25:17 +01:00
files-4.14/arch/mips/boot/dts lantiq: kernel 4.14: use vbus-supply devicetree property 2018-05-17 07:40:19 +02:00
image lantiq: complete AVM FRITZ!Box 3370 support 2018-05-17 07:40:19 +02:00
patches-4.14 lantiq: atm: fix ifx_atm driver integration 2018-06-18 15:26:41 +02:00
xrx200 lantiq-vdsl-fw: update to provide recent vectoring firmware 2018-06-15 12:45:37 +02:00
xway lantiq: switch to kernel 4.14 2018-05-17 07:40:19 +02:00
xway_legacy lantiq: switch to kernel 4.14 2018-05-17 07:40:19 +02:00
config-4.14 kernel: enable THIN_ARCHIVES by default 2018-05-22 07:55:20 +02:00
Makefile lantiq: switch to kernel 4.14 2018-05-17 07:40:19 +02:00
modules.mk fix i2c-lantiq module 2012-12-16 10:03:18 +00:00