Added vnc-reflector, corrected typo in vpnc/Config.in added then to menuconfig

SVN-Revision: 2648
This commit is contained in:
Florian Fainelli 2005-12-13 10:22:15 +00:00
parent 10711d7971
commit 9e0057bdf6
7 changed files with 69 additions and 1 deletions

View file

@ -130,6 +130,7 @@ source "package/ttcp/Config.in"
source "package/ulogd/Config.in"
source "package/updatedd/Config.in"
source "package/vgp/Config.in"
source "package/vnc-reflector/Config.in"
source "package/vpnc/Config.in"
source "package/vrrpd/Config.in"
source "package/vsftpd/Config.in"

View file

@ -206,6 +206,7 @@ package-$(BR2_PACKAGE_USTL) += ustl
package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
package-$(BR2_PACKAGE_UDEV) += udev
package-$(BR2_PACKAGE_VGP) += vgp
package_$(BR2_PACKAGE_VNC_REFLECTOR) += vnc-reflector
package-$(BR2_PACKAGE_VPNC) += vpnc
package-$(BR2_PACKGE_VRRPD) += vrrpd
package-$(BR2_PACKAGE_VTUN) += vtun
@ -315,6 +316,7 @@ tcpdump-compile: libpcap-compile
tinc-compile: zlib-compile openssl-compile liblzo-compile
tor-compile: libevent-compile openssl-compile zlib-compile
usbutils-compile: libusb-compile
vnc-reflector-compile: jpeg-compile zlib-compile
vpnc-compile: libgcrypt-compile libgpg-error-compile
vtun-compile: zlib-compile openssl-compile liblzo-compile
wificonf-compile: wireless-tools-compile nvram-compile

View file

@ -0,0 +1,7 @@
config BR2_PACKAGE_VNC_REFLECTOR
tristate "vnc-reflector....................... VNC proxy for multiple clients"
default m if CONFIG_DEVEL
depends on BR2_PACKAGE_JPEG
depends on BR2_PACKAGE_ZLIB
help
VNC Reflector is a specialized VNC server which acts as a proxy sitting between real VNC server (a host) and a number of VNC clients. It was designed to work efficiently with large number of clients.

View file

@ -0,0 +1,31 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vnc-reflector
PKG_VERSION:=1.2.4
PKG_RELEASE:=1
PKG_MD5SUM:=
PKG_SOURCE_URL:=@SF/vnc-reflector
PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,VNC_REFLECTOR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
$(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
install -d $(PKG_INSTALL_DIR)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/vncreflector $(PKG_INSTALL_DIR)/usr/sbin/
touch $@
$(IPKG_VNC_REFLECTOR):
mkdir -p $(IDIR_VNC_REFLECTOR)
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VNC_REFLECTOR)/
$(RSTRIP) $(IDIR_VNC_REFLECTOR)
$(IPKG_BUILD) $(IDIR_VNC_REFLECTOR) $(PACKAGE_DIR)

View file

@ -0,0 +1,6 @@
Package: vnc-reflector
Depends: jpeg, zlib
Section: net
Architecture: mipsel
Priority: optional
Description: VNC Reflector is a specialized VNC server which acts as a proxy sitting between real VNC server (a host) and a number of VNC clients. It was designed to work efficiently with large number of clients.

View file

@ -0,0 +1,21 @@
diff -urN orig/vnc_reflector/Makefile vnc_reflector/Makefile
--- orig/vnc_reflector/Makefile 2003-04-16 19:32:42.000000000 +0200
+++ vnc_reflector/Makefile 2005-12-13 11:08:09.000000000 +0100
@@ -14,7 +14,7 @@
#
# Variables you might want to edit: CFLAGS, CONFFLAGS
-IFLAGS = -I.
+IFLAGS = -I. -I$(STAGING_DIR)/usr/include
# Production
CFLAGS = -O2 $(IFLAGS)
@@ -29,7 +29,7 @@
CONFFLAGS = -DUSE_POLL
# Link with zlib and JPEG libraries
-LDFLAGS = -L/usr/local/lib -lz -ljpeg
+LDFLAGS = -L$(STAGING_DIR)/usr/lib -lz -ljpeg
PROG = vncreflector

View file

@ -1,5 +1,5 @@
config BR2_PACKAGE_VPNC
tristate "vpnc............................. client for cisco3000 VPN Concentrator."
tristate "vpnc............................. VPN client for Cisco 3000"
default m if CONFIG_DEVEL
depends on BR2_PACKAGE_KMOD_TUN
depends on BR2_PACKAGE_LIBGPG_ERROR