Added vpnc, a cicso3000 vpn concentrator client
SVN-Revision: 2647
This commit is contained in:
parent
636b2d3d83
commit
10711d7971
6 changed files with 75 additions and 0 deletions
|
@ -130,6 +130,7 @@ source "package/ttcp/Config.in"
|
|||
source "package/ulogd/Config.in"
|
||||
source "package/updatedd/Config.in"
|
||||
source "package/vgp/Config.in"
|
||||
source "package/vpnc/Config.in"
|
||||
source "package/vrrpd/Config.in"
|
||||
source "package/vsftpd/Config.in"
|
||||
source "package/vtun/Config.in"
|
||||
|
|
|
@ -206,6 +206,7 @@ package-$(BR2_PACKAGE_USTL) += ustl
|
|||
package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
|
||||
package-$(BR2_PACKAGE_UDEV) += udev
|
||||
package-$(BR2_PACKAGE_VGP) += vgp
|
||||
package-$(BR2_PACKAGE_VPNC) += vpnc
|
||||
package-$(BR2_PACKGE_VRRPD) += vrrpd
|
||||
package-$(BR2_PACKAGE_VTUN) += vtun
|
||||
package-$(BR2_PACKAGE_VSFTPD) += vsftpd
|
||||
|
@ -314,6 +315,7 @@ tcpdump-compile: libpcap-compile
|
|||
tinc-compile: zlib-compile openssl-compile liblzo-compile
|
||||
tor-compile: libevent-compile openssl-compile zlib-compile
|
||||
usbutils-compile: libusb-compile
|
||||
vpnc-compile: libgcrypt-compile libgpg-error-compile
|
||||
vtun-compile: zlib-compile openssl-compile liblzo-compile
|
||||
wificonf-compile: wireless-tools-compile nvram-compile
|
||||
wknock-compile: libpcap-compile
|
||||
|
|
8
openwrt/package/vpnc/Config.in
Executable file
8
openwrt/package/vpnc/Config.in
Executable file
|
@ -0,0 +1,8 @@
|
|||
config BR2_PACKAGE_VPNC
|
||||
tristate "vpnc............................. client for cisco3000 VPN Concentrator."
|
||||
default m if CONFIG_DEVEL
|
||||
depends on BR2_PACKAGE_KMOD_TUN
|
||||
depends on BR2_PACKAGE_LIBGPG_ERROR
|
||||
depends on BR2_PACKAGE_LIBGCRYPT
|
||||
help
|
||||
Client for cisco3000 VPN Concentrator.
|
31
openwrt/package/vpnc/Makefile
Executable file
31
openwrt/package/vpnc/Makefile
Executable file
|
@ -0,0 +1,31 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vpnc
|
||||
PKG_VERSION:=0.3.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
|
||||
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,VPNC,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_VPNC):
|
||||
mkdir -p $(IDIR_VPNC)
|
||||
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
|
||||
$(RSTRIP) $(IDIR_VPNC)
|
||||
$(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)
|
6
openwrt/package/vpnc/ipkg/vpnc.control
Executable file
6
openwrt/package/vpnc/ipkg/vpnc.control
Executable file
|
@ -0,0 +1,6 @@
|
|||
Package: vpnc
|
||||
Section: net
|
||||
Architecture: mipsel
|
||||
Priority: optional
|
||||
Description: client for cisco3000 VPN Concentrator.
|
||||
Depends: libgpg-error libgcrypt kmod-tun
|
27
openwrt/package/vpnc/patches/01-no_man.patch
Normal file
27
openwrt/package/vpnc/patches/01-no_man.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
diff -urN orig/vpnc-0.3.3/Makefile vpnc-0.3.3/Makefile
|
||||
--- orig/vpnc-0.3.3/Makefile 2005-05-01 22:30:35.000000000 +0200
|
||||
+++ vpnc-0.3.3/Makefile 2005-12-13 10:30:56.000000000 +0100
|
||||
@@ -22,9 +22,8 @@
|
||||
SBINDIR=$(PREFIX)/sbin
|
||||
MANDIR=$(PREFIX)/share/man
|
||||
|
||||
-CC=gcc
|
||||
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
||||
-LDFLAGS=-g $(shell libgcrypt-config --libs)
|
||||
+CFLAGS=-W -Wall -O -I$(STAGING_DIR)/usr/include '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
||||
+LDFLAGS=-L$(STAGING_DIR)/usr/lib $(shell libgcrypt-config --libs)
|
||||
|
||||
ifeq ($(shell uname -s), Linux)
|
||||
SYSDEP=sysdep-linux.o
|
||||
@@ -83,10 +82,9 @@
|
||||
all : vpnc
|
||||
|
||||
install :
|
||||
- install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8
|
||||
+ install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR)
|
||||
install vpnc.conf vpnc-script $(DESTDIR)$(ETCDIR)
|
||||
install vpnc vpnc-disconnect $(DESTDIR)$(SBINDIR)
|
||||
- install vpnc.8 $(DESTDIR)$(MANDIR)/man8
|
||||
|
||||
install-strip :
|
||||
install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8
|
Loading…
Reference in a new issue