ppl: upgrade to 1.0
Signed-off-by: Luka Perkov <lperkov@cisco.com> SVN-Revision: 37786
This commit is contained in:
parent
dc7164d4ef
commit
884ae69189
4 changed files with 49 additions and 119 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2009 OpenWrt.org
|
# Copyright (C) 2009-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,14 +7,17 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ppl
|
PKG_NAME:=ppl
|
||||||
PKG_VERSION:=0.10.2
|
PKG_VERSION:=1.0
|
||||||
|
|
||||||
PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
|
PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/1.0/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
|
PKG_MD5SUM:=e8caeb84cd858f64b36333c368891c7b
|
||||||
|
|
||||||
HOST_FIXUP:=autoreconf
|
HOST_FIXUP:=autoreconf
|
||||||
|
|
||||||
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
HOST_CONFIGURE_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
unexport CFLAGS
|
unexport CFLAGS
|
||||||
|
@ -31,5 +34,4 @@ define Host/Configure
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
||||||
$(eval $(call HostBuild))
|
$(eval $(call HostBuild))
|
||||||
|
|
41
tools/ppl/patches/001-gmp-conflicts.patch
Normal file
41
tools/ppl/patches/001-gmp-conflicts.patch
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
--- a/src/mp_std_bits.cc
|
||||||
|
+++ b/src/mp_std_bits.cc
|
||||||
|
@@ -25,6 +25,9 @@ site: http://bugseng.com/products/ppl/ . */
|
||||||
|
#include "ppl-config.h"
|
||||||
|
#include "mp_std_bits_defs.hh"
|
||||||
|
|
||||||
|
+#if __GNU_MP_VERSION < 5 \
|
||||||
|
+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
|
||||||
|
+
|
||||||
|
const bool std::numeric_limits<mpz_class>::is_specialized;
|
||||||
|
const int std::numeric_limits<mpz_class>::digits;
|
||||||
|
const int std::numeric_limits<mpz_class>::digits10;
|
||||||
|
@@ -70,3 +73,6 @@ const bool std::numeric_limits<mpq_class>::is_modulo;
|
||||||
|
const bool std::numeric_limits<mpq_class>::traps;
|
||||||
|
const bool std::numeric_limits<mpq_class>::tininess_before;
|
||||||
|
const std::float_round_style std::numeric_limits<mpq_class>::round_style;
|
||||||
|
+
|
||||||
|
+#endif // __GNU_MP_VERSION < 5
|
||||||
|
+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
|
||||||
|
--- a/src/mp_std_bits.defs.hh
|
||||||
|
+++ b/src/mp_std_bits.defs.hh
|
||||||
|
@@ -38,6 +38,9 @@
|
||||||
|
#endif // defined(PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS)
|
||||||
|
void swap(mpq_class& x, mpq_class& y);
|
||||||
|
|
||||||
|
+#if __GNU_MP_VERSION < 5 \
|
||||||
|
+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
|
||||||
|
+
|
||||||
|
namespace std {
|
||||||
|
|
||||||
|
#ifdef PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS
|
||||||
|
@@ -164,6 +167,9 @@
|
||||||
|
|
||||||
|
} // namespace std
|
||||||
|
|
||||||
|
+#endif // __GNU_MP_VERSION < 5
|
||||||
|
+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
|
||||||
|
+
|
||||||
|
#include "mp_std_bits.inlines.hh"
|
||||||
|
|
||||||
|
#endif // !defined(PPL_mp_std_bits_defs_hh)
|
|
@ -1,38 +0,0 @@
|
||||||
From: Roberto Bagnara <bagnara@cs.unipr.it>
|
|
||||||
Date: Sat, 9 Jan 2010 15:32:08 +0000 (+0100)
|
|
||||||
Subject: Added support for GMP 5.0.
|
|
||||||
X-Git-Url: http://www.cs.unipr.it/git/gitweb.cgi?p=ppl%2Fppl.git;a=commitdiff_plain;h=9c19bc2b318a35016e0189f9552c98910be37f53
|
|
||||||
|
|
||||||
Added support for GMP 5.0.
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/m4/ac_check_gmp.m4 b/m4/ac_check_gmp.m4
|
|
||||||
index 60cecdc..15acb18 100644
|
|
||||||
--- a/m4/ac_check_gmp.m4
|
|
||||||
+++ b/m4/ac_check_gmp.m4
|
|
||||||
@@ -71,6 +71,10 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
|
|
||||||
#GMP version 4.1.3 or higher is required
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifndef BITS_PER_MP_LIMB
|
|
||||||
+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
int
|
|
||||||
main() {
|
|
||||||
std::string header_version;
|
|
||||||
@@ -97,11 +101,11 @@ main() {
|
|
||||||
return 1;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
|
|
||||||
- || GMP_LIMB_BITS != mp_bits_per_limb) {
|
|
||||||
+ if (sizeof(mp_limb_t)*CHAR_BIT != BITS_PER_MP_LIMB
|
|
||||||
+ || BITS_PER_MP_LIMB != mp_bits_per_limb) {
|
|
||||||
std::cerr
|
|
||||||
<< "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
|
|
||||||
- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
|
|
||||||
+ << "header gives " << BITS_PER_MP_LIMB << ";\n"
|
|
||||||
<< "library gives " << mp_bits_per_limb << ".\n"
|
|
||||||
<< "This probably means you are on a bi-arch system and\n"
|
|
||||||
<< "you are compiling with the wrong header or linking with\n"
|
|
|
@ -1,75 +0,0 @@
|
||||||
--- a/interfaces/Prolog/Ciao/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/Ciao/Makefile.am
|
|
||||||
@@ -165,7 +165,7 @@ $(NO_UNDEFINED_FLAG) \
|
|
||||||
-module \
|
|
||||||
-avoid-version
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_ciao.po
|
|
||||||
+pkgdata_DATA = ppl_ciao.po
|
|
||||||
|
|
||||||
ppl_ciao.pl: $(interface_generator_dependencies)
|
|
||||||
$(M4) --prefix-builtin -I../.. -I$(srcdir)/.. -I$(srcdir)/../.. \
|
|
||||||
--- a/interfaces/Prolog/GNU/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/GNU/Makefile.am
|
|
||||||
@@ -164,7 +164,7 @@ ppl_gprolog.pl: $(interface_generator_de
|
|
||||||
$(M4) --prefix-builtin -I../.. -I$(srcdir)/.. -I$(srcdir)/../.. \
|
|
||||||
$(srcdir)/ppl_interface_generator_gprolog_pl.m4 > $@
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_gprolog.pl
|
|
||||||
+pkgdata_DATA = ppl_gprolog.pl
|
|
||||||
|
|
||||||
bin_PROGRAMS = ppl_gprolog
|
|
||||||
|
|
||||||
--- a/interfaces/Prolog/SICStus/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/SICStus/Makefile.am
|
|
||||||
@@ -68,7 +68,7 @@ ppl_sicstus_SOURCES =
|
|
||||||
|
|
||||||
if ENABLE_SHARED
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_sicstus.pl ppl_sicstus.s.o
|
|
||||||
+pkgdata_DATA = ppl_sicstus.pl ppl_sicstus.s.o
|
|
||||||
|
|
||||||
ppl_sicstus.so: ppl_sicstus.pl $(top_builddir)/src/libppl.la $(WATCHDOG_LIBRARY) libppl_sicstus.la
|
|
||||||
$(LIBTOOL) --mode=link --tag=CXX \
|
|
||||||
@@ -86,7 +86,7 @@ install-data-local: ppl_sicstus.so
|
|
||||||
|
|
||||||
else !ENABLE_SHARED
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_sicstus.pl
|
|
||||||
+pkgdata_DATA = ppl_sicstus.pl
|
|
||||||
|
|
||||||
endif !ENABLE_SHARED
|
|
||||||
|
|
||||||
--- a/interfaces/Prolog/SWI/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/SWI/Makefile.am
|
|
||||||
@@ -184,7 +184,7 @@ $(NO_UNDEFINED_FLAG) \
|
|
||||||
bin_PROGRAMS = ppl_pl
|
|
||||||
ppl_pl_SOURCES = ppl_pl.cc
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_swiprolog.pl
|
|
||||||
+pkgdata_DATA = ppl_swiprolog.pl
|
|
||||||
|
|
||||||
CLPQ_TESTS_NONSTRICT = \
|
|
||||||
ack.clpq \
|
|
||||||
--- a/interfaces/Prolog/XSB/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/XSB/Makefile.am
|
|
||||||
@@ -183,7 +183,7 @@ $(NO_UNDEFINED_FLAG) \
|
|
||||||
-module \
|
|
||||||
-avoid-version
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_xsb.xwam
|
|
||||||
+pkgdata_DATA = ppl_xsb.xwam
|
|
||||||
|
|
||||||
ppl_xsb.xwam: ppl_xsb.H ppl_xsb.cc libppl_xsb.la
|
|
||||||
cp -f ppl_xsb.cc ppl_xsb.c
|
|
||||||
--- a/interfaces/Prolog/YAP/Makefile.am
|
|
||||||
+++ b/interfaces/Prolog/YAP/Makefile.am
|
|
||||||
@@ -173,7 +173,7 @@ $(NO_UNDEFINED_FLAG) \
|
|
||||||
-module \
|
|
||||||
-avoid-version
|
|
||||||
|
|
||||||
-pkglib_DATA = ppl_yap.pl
|
|
||||||
+pkgdata_DATA = ppl_yap.pl
|
|
||||||
|
|
||||||
CLPQ_TESTS_NONSTRICT = \
|
|
||||||
ack.clpq \
|
|
Loading…
Reference in a new issue