65 lines
1.5 KiB
Nix
65 lines
1.5 KiB
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ (modulesPath + "/profiles/qemu-guest.nix")
|
|
];
|
|
|
|
boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_blk" ];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ "kvm-amd" ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
fileSystems."/" =
|
|
{ device = "/dev/disk/by-uuid/391c15a3-9c2d-44e7-ba64-7cfcdc5c7a4e";
|
|
fsType = "ext4";
|
|
};
|
|
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/vda";
|
|
|
|
time.timeZone = "Europe/London";
|
|
i18n.defaultLocale = "en_US.UTF-8";
|
|
services.openssh.enable = true;
|
|
|
|
services.xserver.videoDrivers = [ "nvidia" ];
|
|
hardware.graphics.enable = true;
|
|
hardware.nvidia = {
|
|
modesetting.enable = true;
|
|
nvidiaPersistenced = true;
|
|
package = config.boot.kernelPackages.nvidiaPackages.stable;
|
|
open = false;
|
|
};
|
|
|
|
networking = {
|
|
hostName = "nova";
|
|
search = ["wolfgirl.systems"];
|
|
nameservers = [ "9.9.9.10" "149.112.112.10" "2620:fe::10" "2620:fe::fe:10"];
|
|
dhcpcd.enable = true;
|
|
interfaces = {
|
|
ens3.ipv6.addresses = [{
|
|
address = "2a0f:85c2:7::3b";
|
|
prefixLength = 126;
|
|
}];
|
|
};
|
|
defaultGateway6 = {
|
|
address = "2a0f:85c2:7::1";
|
|
interface = "ens3";
|
|
};
|
|
};
|
|
|
|
swapDevices = [ {
|
|
device = "/swapfile";
|
|
size = 4*1024;
|
|
randomEncryption.enable = true;
|
|
}];
|
|
|
|
environment.etc."info" = {
|
|
mode = "0644";
|
|
text = builtins.readFile ./info/nova;
|
|
};
|
|
|
|
system.stateVersion = "24.05";
|
|
}
|