nixos/hosts/alice.nix
2024-10-11 13:09:45 -04:00

61 lines
1.5 KiB
Nix

{ config, lib, pkgs, modulesPath, ... }:
{
imports =
[ (modulesPath + "/profiles/qemu-guest.nix")
];
boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ahci" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
boot.initrd.kernelModules = [ ];
boot.kernelModules = [ ];
boot.extraModulePackages = [ ];
fileSystems."/" =
{ device = "/dev/disk/by-uuid/1aeaf426-9dec-40b8-b472-5785832444a6";
fsType = "ext4";
};
fileSystems."/data" =
{ device = "/dev/disk/by-uuid/9d1fc1f3-aeb8-4f08-aa08-814378052a90";
fsType = "ext4";
};
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
boot.loader.grub.enable = true;
boot.loader.grub.device = "/dev/sda";
time.timeZone = "America/New_York";
i18n.defaultLocale = "en_US.UTF-8";
services.openssh.enable = true;
networking = {
hostName = "alice";
search = ["wolfgirl.systems"];
nameservers = [ "9.9.9.10" "149.112.112.10" "2620:fe::10" "2620:fe::fe:10"];
dhcpcd.enable = false;
interfaces.enp6s18.ipv4.addresses = [{
address = "207.167.121.11";
prefixLength = 24;
}];
interfaces.enp6s18.ipv6.addresses = [{
address = "2602:fbf5:1::cfa7:790b";
prefixLength = 48;
}];
defaultGateway = {
address = "207.167.121.1";
interface = "enp6s18";
};
defaultGateway6 = {
address = "2602:fbf5:1::1";
interface = "enp6s18";
};
};
environment.etc."info" = {
mode = "0644";
text = builtins.readFile ./info/alice;
};
system.stateVersion = "24.05";
}