981e3b354a
This patch improves support for the device considerably. 1. The wifi didn't work in the initial release. This was because the WMAC of the AR9340 is not connected to the antennas. (However, it can pick up wifi signals, if they are strong enough!) Instead there's a dedicated AR9300 chip on the same board, which works. 2. Ethernet throughput is improved. iperf shows that the hardware can sustain more than 200Mbit/s and no longer drops any packages when the link is under load. Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> Patchwork: http://patchwork.openwrt.org/patch/4461/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38949
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -56,6 +56,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
|
|
ATH79_MACH_MR600, /* OpenMesh MR600 */
|
|
ATH79_MACH_MYNET_N600, /* WD My Net N600 */
|
|
+ ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */
|
|
ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
|
|
ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
|
|
ATH79_MACH_NBG460N, /* Zyxel NBG460N/550N/550NH */
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -67,6 +67,7 @@ obj-$(CONFIG_ATH79_MACH_JWAP003) += mach
|
|
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
|
|
obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
|
|
obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
|
|
+obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
|
|
obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
|
|
obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o
|
|
obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
|
|
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -801,6 +801,17 @@ config ATH79_MACH_MYNET_N600
|
|
select ATH79_DEV_WMAC
|
|
select ATH79_NVRAM
|
|
|
|
+config ATH79_MACH_MYNET_REXT
|
|
+ bool "WD My Net Wi-Fi Range Extender board support"
|
|
+ select SOC_AR934X
|
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
|
+ select ATH79_DEV_ETH
|
|
+ select ATH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_M25P80
|
|
+ select ATH79_DEV_WMAC
|
|
+ select ATH79_NVRAM
|
|
+
|
|
config ATH79_MACH_ZCN_1523H
|
|
bool "Zcomax ZCN-1523H support"
|
|
select SOC_AR724X
|