1db4135e32
Adds preliminary kernel 4.9 support for this target. - Refreshed/Updated all patches Added 3 new patches: - 093 --> Add virtual PCI MMIO mapping - 230 --> Remove deprecated code - 240 --> Rework AT24 eeprom code to use the new NVMEM API Compiled & tested on cns3xxx (gw2388) Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
30 lines
892 B
Diff
30 lines
892 B
Diff
--- a/arch/arm/mach-cns3xxx/Makefile
|
|
+++ b/arch/arm/mach-cns3xxx/Makefile
|
|
@@ -5,3 +5,5 @@ cns3xxx-y += core.o pm.o
|
|
cns3xxx-$(CONFIG_ATAGS) += devices.o
|
|
cns3xxx-$(CONFIG_PCI) += pcie.o
|
|
cns3xxx-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
|
|
+cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o
|
|
+cns3xxx-$(CONFIG_HOTPLUG_CPU) += hotplug.o
|
|
--- a/arch/arm/mach-cns3xxx/Kconfig
|
|
+++ b/arch/arm/mach-cns3xxx/Kconfig
|
|
@@ -2,6 +2,9 @@ menuconfig ARCH_CNS3XXX
|
|
bool "Cavium Networks CNS3XXX family"
|
|
depends on ARCH_MULTI_V6
|
|
select ARM_GIC
|
|
+ select HAVE_ARM_SCU if SMP
|
|
+ select HAVE_ARM_TWD
|
|
+ select HAVE_SMP
|
|
help
|
|
Support for Cavium Networks CNS3XXX platform.
|
|
|
|
--- a/arch/arm/mach-cns3xxx/core.h
|
|
+++ b/arch/arm/mach-cns3xxx/core.h
|
|
@@ -13,6 +13,7 @@
|
|
|
|
#include <linux/reboot.h>
|
|
|
|
+extern struct smp_operations cns3xxx_smp_ops;
|
|
extern void cns3xxx_timer_init(void);
|
|
|
|
#ifdef CONFIG_CACHE_L2X0
|