openwrtv4/target/linux/adm5120/patches-3.8/009-adm5120_leds_switch_trigger.patch
Gabor Juhos 05de472518 adm5120: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35769
2013-02-24 18:08:14 +00:00

22 lines
831 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -579,4 +579,12 @@ config LEDS_TRIGGER_USBDEV
This allows LEDs to be controlled by the presence/activity of
an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -68,3 +68,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o