2bf9ea6a31
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
180 lines
4.8 KiB
Diff
180 lines
4.8 KiB
Diff
From: Russell King <rmk+kernel@arm.linux.org.uk>
|
|
Date: Fri, 25 Sep 2015 17:43:52 +0100
|
|
Subject: [PATCH] phy: add I2C mdio bus
|
|
|
|
Add an I2C MDIO bus bridge library, to allow phylib to access PHYs which
|
|
are connected to an I2C bus instead of the more conventional MDIO bus.
|
|
Such PHYs can be found in SFP adapters and SFF modules.
|
|
|
|
Since PHYs appear at I2C bus address 0x40..0x5f, and 0x50/0x51 are
|
|
reserved for SFP EEPROMs/diagnostics, we must not allow the MDIO bus
|
|
to access these I2C addresses.
|
|
|
|
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|
---
|
|
create mode 100644 drivers/net/phy/mdio-i2c.c
|
|
create mode 100644 drivers/net/phy/mdio-i2c.h
|
|
|
|
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -105,6 +105,16 @@ config MDIO_HISI_FEMAC
|
|
This module provides a driver for the MDIO busses found in the
|
|
Hisilicon SoC that have an Fast Ethernet MAC.
|
|
|
|
+config MDIO_I2C
|
|
+ tristate
|
|
+ depends on I2C
|
|
+ help
|
|
+ Support I2C based PHYs. This provides a MDIO bus bridged
|
|
+ to I2C to allow PHYs connected in I2C mode to be accessed
|
|
+ using the existing infrastructure.
|
|
+
|
|
+ This is library mode.
|
|
+
|
|
config MDIO_MOXART
|
|
tristate "MOXA ART MDIO interface support"
|
|
depends on ARCH_MOXART
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -33,6 +33,7 @@ obj-$(CONFIG_MDIO_BUS_MUX_MMIOREG) += md
|
|
obj-$(CONFIG_MDIO_CAVIUM) += mdio-cavium.o
|
|
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
|
|
obj-$(CONFIG_MDIO_HISI_FEMAC) += mdio-hisi-femac.o
|
|
+obj-$(CONFIG_MDIO_I2C) += mdio-i2c.o
|
|
obj-$(CONFIG_MDIO_MOXART) += mdio-moxart.o
|
|
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
|
|
obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
|
|
--- /dev/null
|
|
+++ b/drivers/net/phy/mdio-i2c.c
|
|
@@ -0,0 +1,109 @@
|
|
+/*
|
|
+ * MDIO I2C bridge
|
|
+ *
|
|
+ * Copyright (C) 2015-2016 Russell King
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ *
|
|
+ * Network PHYs can appear on I2C buses when they are part of SFP module.
|
|
+ * This driver exposes these PHYs to the networking PHY code, allowing
|
|
+ * our PHY drivers access to these PHYs, and so allowing configuration
|
|
+ * of their settings.
|
|
+ */
|
|
+#include <linux/i2c.h>
|
|
+#include <linux/phy.h>
|
|
+
|
|
+#include "mdio-i2c.h"
|
|
+
|
|
+/*
|
|
+ * I2C bus addresses 0x50 and 0x51 are normally an EEPROM, which is
|
|
+ * specified to be present in SFP modules. These correspond with PHY
|
|
+ * addresses 16 and 17. Disallow access to these "phy" addresses.
|
|
+ */
|
|
+static bool i2c_mii_valid_phy_id(int phy_id)
|
|
+{
|
|
+ return phy_id != 0x10 && phy_id != 0x11;
|
|
+}
|
|
+
|
|
+static unsigned int i2c_mii_phy_addr(int phy_id)
|
|
+{
|
|
+ return phy_id + 0x40;
|
|
+}
|
|
+
|
|
+static int i2c_mii_read(struct mii_bus *bus, int phy_id, int reg)
|
|
+{
|
|
+ struct i2c_adapter *i2c = bus->priv;
|
|
+ struct i2c_msg msgs[2];
|
|
+ u8 data[2], dev_addr = reg;
|
|
+ int bus_addr, ret;
|
|
+
|
|
+ if (!i2c_mii_valid_phy_id(phy_id))
|
|
+ return 0xffff;
|
|
+
|
|
+ bus_addr = i2c_mii_phy_addr(phy_id);
|
|
+ msgs[0].addr = bus_addr;
|
|
+ msgs[0].flags = 0;
|
|
+ msgs[0].len = 1;
|
|
+ msgs[0].buf = &dev_addr;
|
|
+ msgs[1].addr = bus_addr;
|
|
+ msgs[1].flags = I2C_M_RD;
|
|
+ msgs[1].len = sizeof(data);
|
|
+ msgs[1].buf = data;
|
|
+
|
|
+ ret = i2c_transfer(i2c, msgs, ARRAY_SIZE(msgs));
|
|
+ if (ret != ARRAY_SIZE(msgs))
|
|
+ return 0xffff;
|
|
+
|
|
+ return data[0] << 8 | data[1];
|
|
+}
|
|
+
|
|
+static int i2c_mii_write(struct mii_bus *bus, int phy_id, int reg, u16 val)
|
|
+{
|
|
+ struct i2c_adapter *i2c = bus->priv;
|
|
+ struct i2c_msg msg;
|
|
+ int ret;
|
|
+ u8 data[3];
|
|
+
|
|
+ if (!i2c_mii_valid_phy_id(phy_id))
|
|
+ return 0;
|
|
+
|
|
+ data[0] = reg;
|
|
+ data[1] = val >> 8;
|
|
+ data[2] = val;
|
|
+
|
|
+ msg.addr = i2c_mii_phy_addr(phy_id);
|
|
+ msg.flags = 0;
|
|
+ msg.len = 3;
|
|
+ msg.buf = data;
|
|
+
|
|
+ ret = i2c_transfer(i2c, &msg, 1);
|
|
+
|
|
+ return ret < 0 ? ret : 0;
|
|
+}
|
|
+
|
|
+struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c)
|
|
+{
|
|
+ struct mii_bus *mii;
|
|
+
|
|
+ if (!i2c_check_functionality(i2c, I2C_FUNC_I2C))
|
|
+ return ERR_PTR(-EINVAL);
|
|
+
|
|
+ mii = mdiobus_alloc();
|
|
+ if (!mii)
|
|
+ return ERR_PTR(-ENOMEM);
|
|
+
|
|
+ snprintf(mii->id, MII_BUS_ID_SIZE, "i2c:%s", dev_name(parent));
|
|
+ mii->parent = parent;
|
|
+ mii->read = i2c_mii_read;
|
|
+ mii->write = i2c_mii_write;
|
|
+ mii->priv = i2c;
|
|
+
|
|
+ return mii;
|
|
+}
|
|
+EXPORT_SYMBOL_GPL(mdio_i2c_alloc);
|
|
+
|
|
+MODULE_AUTHOR("Russell King");
|
|
+MODULE_DESCRIPTION("MDIO I2C bridge library");
|
|
+MODULE_LICENSE("GPL v2");
|
|
--- /dev/null
|
|
+++ b/drivers/net/phy/mdio-i2c.h
|
|
@@ -0,0 +1,19 @@
|
|
+/*
|
|
+ * MDIO I2C bridge
|
|
+ *
|
|
+ * Copyright (C) 2015 Russell King
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ */
|
|
+#ifndef MDIO_I2C_H
|
|
+#define MDIO_I2C_H
|
|
+
|
|
+struct device;
|
|
+struct i2c_adapter;
|
|
+struct mii_bus;
|
|
+
|
|
+struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c);
|
|
+
|
|
+#endif
|