7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
25 lines
810 B
Diff
25 lines
810 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -200,6 +200,12 @@ config MTD_MYLOADER_PARTS
|
|
You will still need the parsing functions to be called by the driver
|
|
for your particular device. It won't happen automatically.
|
|
|
|
+config MTD_TPLINK_PARTS
|
|
+ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
|
|
+ depends on ATH79
|
|
+ ---help---
|
|
+ TBD.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
#
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -17,6 +17,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63
|
|
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
obj-y += parsers/
|
|
+obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
|
|
obj-$(CONFIG_MTD_CYBERTAN_PARTS) += cybertan_part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|