fce21ae4cc
Right now all brcm2708 patches are extracted from the non-mainline raspberrypi/linux git tree. Many of them are hacks and/or are unneeded in LEDE. Raspberry Pi is getting better and better mainline support so it would be nice to finally start maintaining patches in a cleaner way: 1) Backport patches accepted in upstream tree 2) Start using upstream drivers 3) Pick only these patches that are needed for more complete support Handling above tasks requires grouping patches - ideally using the same prefixes as generic ones. It means we should rename existing patches to use some high prefix. This will allow e.g. use 0xx for backported code. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Florian Fainelli <f.fainelli@gmail.com> Acked-by: Stijn Tintel <stijn@linux-ipv6.be>
225 lines
4.5 KiB
Diff
225 lines
4.5 KiB
Diff
From 41620ad7f4b059be162f615a7be423df78406d29 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Tue, 24 May 2016 16:30:05 +0100
|
|
Subject: [PATCH] BCM270X_DT: Add bcm2708-rpi-0-w.dts
|
|
|
|
Add DT support for the Pi Zero W. N.B. It will not be loaded
|
|
automatically without a corresponding change to the firmware.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm2708-rpi-0-w.dts | 197 ++++++++++++++++++++++++++++++++++
|
|
2 files changed, 198 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm2708-rpi-0-w.dts
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -4,6 +4,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
|
|
bcm2708-rpi-b.dtb \
|
|
bcm2708-rpi-b-plus.dtb \
|
|
bcm2708-rpi-cm.dtb \
|
|
+ bcm2708-rpi-0-w.dtb \
|
|
bcm2709-rpi-2-b.dtb \
|
|
bcm2710-rpi-3-b.dtb \
|
|
bcm2710-rpi-cm3.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm2708-rpi-0-w.dts
|
|
@@ -0,0 +1,197 @@
|
|
+/dts-v1/;
|
|
+
|
|
+#include "bcm2708.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Raspberry Pi Zero W";
|
|
+};
|
|
+
|
|
+&gpio {
|
|
+ sdhost_pins: sdhost_pins {
|
|
+ brcm,pins = <48 49 50 51 52 53>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ };
|
|
+
|
|
+ spi0_pins: spi0_pins {
|
|
+ brcm,pins = <9 10 11>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ };
|
|
+
|
|
+ spi0_cs_pins: spi0_cs_pins {
|
|
+ brcm,pins = <8 7>;
|
|
+ brcm,function = <1>; /* output */
|
|
+ };
|
|
+
|
|
+ i2c0_pins: i2c0 {
|
|
+ brcm,pins = <0 1>;
|
|
+ brcm,function = <4>;
|
|
+ };
|
|
+
|
|
+ i2c1_pins: i2c1 {
|
|
+ brcm,pins = <2 3>;
|
|
+ brcm,function = <4>;
|
|
+ };
|
|
+
|
|
+ i2s_pins: i2s {
|
|
+ brcm,pins = <18 19 20 21>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ };
|
|
+
|
|
+ sdio_pins: sdio_pins {
|
|
+ brcm,pins = <34 35 36 37 38 39>;
|
|
+ brcm,function = <7>; /* ALT3 = SD1 */
|
|
+ brcm,pull = <0 2 2 2 2 2>;
|
|
+ };
|
|
+
|
|
+ bt_pins: bt_pins {
|
|
+ brcm,pins = <43>;
|
|
+ brcm,function = <4>; /* alt0:GPCLK2 */
|
|
+ brcm,pull = <0>; /* none */
|
|
+ };
|
|
+
|
|
+ uart0_pins: uart0_pins {
|
|
+ brcm,pins = <30 31 32 33>;
|
|
+ brcm,function = <7>; /* alt3=UART0 */
|
|
+ brcm,pull = <2 0 0 2>; /* up none none up */
|
|
+ };
|
|
+
|
|
+ uart1_pins: uart1_pins {
|
|
+ brcm,pins;
|
|
+ brcm,function;
|
|
+ brcm,pull;
|
|
+ };
|
|
+
|
|
+ audio_pins: audio_pins {
|
|
+ brcm,pins = <>;
|
|
+ brcm,function = <>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&sdhost {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&sdhost_pins>;
|
|
+ bus-width = <4>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&sdio_pins>;
|
|
+ non-removable;
|
|
+ bus-width = <4>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&fb {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins &bt_pins>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart1_pins>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&spi0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&spi0_pins &spi0_cs_pins>;
|
|
+ cs-gpios = <&gpio 8 1>, <&gpio 7 1>;
|
|
+
|
|
+ spidev0: spidev@0{
|
|
+ compatible = "spidev";
|
|
+ reg = <0>; /* CE0 */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+
|
|
+ spidev1: spidev@1{
|
|
+ compatible = "spidev";
|
|
+ reg = <1>; /* CE1 */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi-max-frequency = <500000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c0_pins>;
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2c1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c1_pins>;
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ clock-frequency = <100000>;
|
|
+};
|
|
+
|
|
+&i2s {
|
|
+ #sound-dai-cells = <0>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2s_pins>;
|
|
+};
|
|
+
|
|
+&random {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&leds {
|
|
+ act_led: act {
|
|
+ label = "led0";
|
|
+ linux,default-trigger = "mmc0";
|
|
+ gpios = <&gpio 47 0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&hdmi {
|
|
+ hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
+};
|
|
+
|
|
+&audio {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&audio_pins>;
|
|
+};
|
|
+
|
|
+/ {
|
|
+ chosen {
|
|
+ bootargs = "8250.nr_uarts=1";
|
|
+ };
|
|
+};
|
|
+
|
|
+/ {
|
|
+ __overrides__ {
|
|
+ uart0 = <&uart0>,"status";
|
|
+ uart1 = <&uart1>,"status";
|
|
+ i2s = <&i2s>,"status";
|
|
+ spi = <&spi0>,"status";
|
|
+ i2c0 = <&i2c0>,"status";
|
|
+ i2c1 = <&i2c1>,"status";
|
|
+ i2c2_iknowwhatimdoing = <&i2c2>,"status";
|
|
+ i2c0_baudrate = <&i2c0>,"clock-frequency:0";
|
|
+ i2c1_baudrate = <&i2c1>,"clock-frequency:0";
|
|
+ i2c2_baudrate = <&i2c2>,"clock-frequency:0";
|
|
+
|
|
+ act_led_gpio = <&act_led>,"gpios:4";
|
|
+ act_led_activelow = <&act_led>,"gpios:8";
|
|
+ act_led_trigger = <&act_led>,"linux,default-trigger";
|
|
+
|
|
+ audio = <&audio>,"status";
|
|
+ watchdog = <&watchdog>,"status";
|
|
+ random = <&random>,"status";
|
|
+ sd_overclock = <&sdhost>,"brcm,overclock-50:0";
|
|
+ sd_force_pio = <&sdhost>,"brcm,force-pio?";
|
|
+ sd_pio_limit = <&sdhost>,"brcm,pio-limit:0";
|
|
+ sd_debug = <&sdhost>,"brcm,debug";
|
|
+ };
|
|
+};
|