fce21ae4cc
Right now all brcm2708 patches are extracted from the non-mainline raspberrypi/linux git tree. Many of them are hacks and/or are unneeded in LEDE. Raspberry Pi is getting better and better mainline support so it would be nice to finally start maintaining patches in a cleaner way: 1) Backport patches accepted in upstream tree 2) Start using upstream drivers 3) Pick only these patches that are needed for more complete support Handling above tasks requires grouping patches - ideally using the same prefixes as generic ones. It means we should rename existing patches to use some high prefix. This will allow e.g. use 0xx for backported code. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Florian Fainelli <f.fainelli@gmail.com> Acked-by: Stijn Tintel <stijn@linux-ipv6.be>
325 lines
9.5 KiB
Diff
325 lines
9.5 KiB
Diff
From fcfe9087b79176b5d8afd0ecc4c66013866ef239 Mon Sep 17 00:00:00 2001
|
|
From: Gordon Garrity <gordon@iqaudio.com>
|
|
Date: Sat, 8 Mar 2014 16:56:57 +0000
|
|
Subject: [PATCH] Add IQaudIO Sound Card support for Raspberry Pi
|
|
|
|
Set a limit of 0dB on Digital Volume Control
|
|
|
|
The main volume control in the PCM512x DAC has a range up to
|
|
+24dB. This is dangerously loud and can potentially cause massive
|
|
clipping in the output stages. Therefore this sets a sensible
|
|
limit of 0dB for this control.
|
|
|
|
Allow up to 24dB digital gain to be applied when using IQAudIO DAC+
|
|
|
|
24db_digital_gain DT param can be used to specify that PCM512x
|
|
codec "Digital" volume control should not be limited to 0dB gain,
|
|
and if specified will allow the full 24dB gain.
|
|
|
|
Modify IQAudIO DAC+ ASoC driver to set card/dai config from dt
|
|
|
|
Add the ability to set the card name, dai name and dai stream name, from
|
|
dt config.
|
|
|
|
Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
|
|
IQaudIO: auto-mute for AMP+ and DigiAMP+
|
|
|
|
IQAudIO amplifier mute via GPIO22. Add dt params for "one-shot" unmute
|
|
and auto mute.
|
|
|
|
Revision 2, auto mute implementing HiassofT suggestion to mute/unmute
|
|
using set_bias_level, rather than startup/shutdown....
|
|
"By default DAPM waits 5 seconds (pmdown_time) before shutting down
|
|
playback streams so a close/stop immediately followed by open/start
|
|
doesn't trigger an amp mute+unmute."
|
|
|
|
Tested on both AMP+ (via DAC+) and DigiAMP+, with both options...
|
|
|
|
dtoverlay=iqaudio-dacplus,unmute_amp
|
|
"one-shot" unmute when kernel module loads.
|
|
|
|
dtoverlay=iqaudio-dacplus,auto_mute_amp
|
|
Unmute amp when ALSA device opened by a client. Mute, with 5 second delay
|
|
when ALSA device closed. (Re-opening the device within the 5 second close
|
|
window, will cancel mute.)
|
|
|
|
Revision 4, using gpiod.
|
|
|
|
Revision 5, clean-up formatting before adding mute code.
|
|
- Convert tab plus 4 space formatting to 2x tab
|
|
- Remove '// NOT USED' commented code
|
|
|
|
Revision 6, don't attempt to "one-shot" unmute amp, unless card is
|
|
successfully registered.
|
|
|
|
Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
---
|
|
sound/soc/bcm/Kconfig | 7 ++
|
|
sound/soc/bcm/Makefile | 2 +
|
|
sound/soc/bcm/iqaudio-dac.c | 234 ++++++++++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 243 insertions(+)
|
|
create mode 100644 sound/soc/bcm/iqaudio-dac.c
|
|
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -37,3 +37,10 @@ config SND_BCM2708_SOC_RPI_DAC
|
|
select SND_SOC_PCM1794A
|
|
help
|
|
Say Y or M if you want to add support for RPi-DAC.
|
|
+
|
|
+config SND_BCM2708_SOC_IQAUDIO_DAC
|
|
+ tristate "Support for IQaudIO-DAC"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_PCM512x_I2C
|
|
+ help
|
|
+ Say Y or M if you want to add support for IQaudIO-DAC.
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -12,7 +12,9 @@ obj-$(CONFIG_SND_SOC_CYGNUS) += snd-soc-
|
|
snd-soc-hifiberry-dac-objs := hifiberry_dac.o
|
|
snd-soc-hifiberry-digi-objs := hifiberry_digi.o
|
|
snd-soc-rpi-dac-objs := rpi-dac.o
|
|
+snd-soc-iqaudio-dac-objs := iqaudio-dac.o
|
|
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DIGI) += snd-soc-hifiberry-digi.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) += snd-soc-rpi-dac.o
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) += snd-soc-iqaudio-dac.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/iqaudio-dac.c
|
|
@@ -0,0 +1,234 @@
|
|
+/*
|
|
+ * ASoC Driver for IQaudIO DAC
|
|
+ *
|
|
+ * Author: Florian Meier <florian.meier@koalo.de>
|
|
+ * Copyright 2013
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/gpio/consumer.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+static bool digital_gain_0db_limit = true;
|
|
+
|
|
+static struct gpio_desc *mute_gpio;
|
|
+
|
|
+static int snd_rpi_iqaudio_dac_init(struct snd_soc_pcm_runtime *rtd)
|
|
+{
|
|
+ if (digital_gain_0db_limit)
|
|
+ {
|
|
+ int ret;
|
|
+ struct snd_soc_card *card = rtd->card;
|
|
+
|
|
+ ret = snd_soc_limit_volume(card, "Digital Playback Volume", 207);
|
|
+ if (ret < 0)
|
|
+ dev_warn(card->dev, "Failed to set volume limit: %d\n", ret);
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int snd_rpi_iqaudio_dac_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+
|
|
+ unsigned int sample_bits =
|
|
+ snd_pcm_format_physical_width(params_format(params));
|
|
+
|
|
+ return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
|
|
+}
|
|
+
|
|
+static void snd_rpi_iqaudio_gpio_mute(struct snd_soc_card *card)
|
|
+{
|
|
+ if (mute_gpio) {
|
|
+ dev_info(card->dev, "%s: muting amp using GPIO22\n",
|
|
+ __func__);
|
|
+ gpiod_set_value_cansleep(mute_gpio, 0);
|
|
+ }
|
|
+}
|
|
+
|
|
+static void snd_rpi_iqaudio_gpio_unmute(struct snd_soc_card *card)
|
|
+{
|
|
+ if (mute_gpio) {
|
|
+ dev_info(card->dev, "%s: un-muting amp using GPIO22\n",
|
|
+ __func__);
|
|
+ gpiod_set_value_cansleep(mute_gpio, 1);
|
|
+ }
|
|
+}
|
|
+
|
|
+static int snd_rpi_iqaudio_set_bias_level(struct snd_soc_card *card,
|
|
+ struct snd_soc_dapm_context *dapm, enum snd_soc_bias_level level)
|
|
+{
|
|
+ struct snd_soc_dai *codec_dai = card->rtd[0].codec_dai;
|
|
+
|
|
+ if (dapm->dev != codec_dai->dev)
|
|
+ return 0;
|
|
+
|
|
+ switch (level) {
|
|
+ case SND_SOC_BIAS_PREPARE:
|
|
+ if (dapm->bias_level != SND_SOC_BIAS_STANDBY)
|
|
+ break;
|
|
+
|
|
+ /* UNMUTE AMP */
|
|
+ snd_rpi_iqaudio_gpio_unmute(card);
|
|
+
|
|
+ break;
|
|
+ case SND_SOC_BIAS_STANDBY:
|
|
+ if (dapm->bias_level != SND_SOC_BIAS_PREPARE)
|
|
+ break;
|
|
+
|
|
+ /* MUTE AMP */
|
|
+ snd_rpi_iqaudio_gpio_mute(card);
|
|
+
|
|
+ break;
|
|
+ default:
|
|
+ break;
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_iqaudio_dac_ops = {
|
|
+ .hw_params = snd_rpi_iqaudio_dac_hw_params,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_iqaudio_dac_dai[] = {
|
|
+{
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "pcm512x-hifi",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "pcm512x.1-004c",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBS_CFS,
|
|
+ .ops = &snd_rpi_iqaudio_dac_ops,
|
|
+ .init = snd_rpi_iqaudio_dac_init,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_iqaudio_dac = {
|
|
+ .owner = THIS_MODULE,
|
|
+ .dai_link = snd_rpi_iqaudio_dac_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_iqaudio_dac_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_iqaudio_dac_probe(struct platform_device *pdev)
|
|
+{
|
|
+ int ret = 0;
|
|
+ bool gpio_unmute = false;
|
|
+
|
|
+ snd_rpi_iqaudio_dac.dev = &pdev->dev;
|
|
+
|
|
+ if (pdev->dev.of_node) {
|
|
+ struct device_node *i2s_node;
|
|
+ struct snd_soc_card *card = &snd_rpi_iqaudio_dac;
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_iqaudio_dac_dai[0];
|
|
+ bool auto_gpio_mute = false;
|
|
+
|
|
+ i2s_node = of_parse_phandle(pdev->dev.of_node,
|
|
+ "i2s-controller", 0);
|
|
+ if (i2s_node) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_node;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_node;
|
|
+ }
|
|
+
|
|
+ digital_gain_0db_limit = !of_property_read_bool(
|
|
+ pdev->dev.of_node, "iqaudio,24db_digital_gain");
|
|
+
|
|
+ if (of_property_read_string(pdev->dev.of_node, "card_name",
|
|
+ &card->name))
|
|
+ card->name = "IQaudIODAC";
|
|
+
|
|
+ if (of_property_read_string(pdev->dev.of_node, "dai_name",
|
|
+ &dai->name))
|
|
+ dai->name = "IQaudIO DAC";
|
|
+
|
|
+ if (of_property_read_string(pdev->dev.of_node,
|
|
+ "dai_stream_name", &dai->stream_name))
|
|
+ dai->stream_name = "IQaudIO DAC HiFi";
|
|
+
|
|
+ /* gpio_unmute - one time unmute amp using GPIO */
|
|
+ gpio_unmute = of_property_read_bool(pdev->dev.of_node,
|
|
+ "iqaudio-dac,unmute-amp");
|
|
+
|
|
+ /* auto_gpio_mute - mute/unmute amp using GPIO */
|
|
+ auto_gpio_mute = of_property_read_bool(pdev->dev.of_node,
|
|
+ "iqaudio-dac,auto-mute-amp");
|
|
+
|
|
+ if (auto_gpio_mute || gpio_unmute) {
|
|
+ mute_gpio = devm_gpiod_get_optional(&pdev->dev, "mute",
|
|
+ GPIOD_OUT_LOW);
|
|
+ if (IS_ERR(mute_gpio)) {
|
|
+ ret = PTR_ERR(mute_gpio);
|
|
+ dev_err(&pdev->dev,
|
|
+ "Failed to get mute gpio: %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ if (auto_gpio_mute && mute_gpio)
|
|
+ snd_rpi_iqaudio_dac.set_bias_level =
|
|
+ snd_rpi_iqaudio_set_bias_level;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_rpi_iqaudio_dac);
|
|
+ if (ret) {
|
|
+ dev_err(&pdev->dev,
|
|
+ "snd_soc_register_card() failed: %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ if (gpio_unmute && mute_gpio)
|
|
+ snd_rpi_iqaudio_gpio_unmute(&snd_rpi_iqaudio_dac);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int snd_rpi_iqaudio_dac_remove(struct platform_device *pdev)
|
|
+{
|
|
+ snd_rpi_iqaudio_gpio_mute(&snd_rpi_iqaudio_dac);
|
|
+
|
|
+ return snd_soc_unregister_card(&snd_rpi_iqaudio_dac);
|
|
+}
|
|
+
|
|
+static const struct of_device_id iqaudio_of_match[] = {
|
|
+ { .compatible = "iqaudio,iqaudio-dac", },
|
|
+ {},
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, iqaudio_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_iqaudio_dac_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-rpi-iqaudio-dac",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = iqaudio_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_iqaudio_dac_probe,
|
|
+ .remove = snd_rpi_iqaudio_dac_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_iqaudio_dac_driver);
|
|
+
|
|
+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for IQAudio DAC");
|
|
+MODULE_LICENSE("GPL v2");
|