f791fb4af4
Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Tim Harvey <tharvey@gateworks.com> [fixes]
21 lines
610 B
Diff
21 lines
610 B
Diff
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -126,4 +126,11 @@ config LEDS_TRIGGER_PANIC
|
|
a different trigger.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -77,3 +77,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|