7e82418372
Update to the latest version of iproute2; see https://lwn.net/Articles/756991/ for a full overview of the changes in 4.17. Remove upstream patch 002-json_print-fix-hidden-64-bit-type-promotion. Backport upstream patch 001-rdma-sync-some-IP-headers-with-glibc fixing rdma compile issue. At the same time re-organize patch numbering so the OpenWRT specific patches start at 100. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
11 lines
394 B
Diff
11 lines
394 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -61,7 +61,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
|
|
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
|
|
YACCFLAGS = -d -t -v
|
|
|
|
-SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma man
|
|
+SUBDIRS=lib ip tc bridge misc genl tipc devlink rdma man
|
|
|
|
LIBNETLINK=../lib/libutil.a ../lib/libnetlink.a
|
|
LDLIBS += $(LIBNETLINK)
|