2d02a4f5bd
Refresh patches. Adapt 704-phy-no-genphy-soft-reset.patch. Remove brcm2708/950-0005-mm-Remove-the-PFN-busy-warning.patch. Compile-tested on brcm2708/bcm2708 and x86/64. Runtime-tested on brcm2708/bcm2708 and x86/64. Fixes the following vulnerabilities: - CVE-2017-7533 - CVE-2017-1000111 - CVE-2017-1000112 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
23 lines
795 B
Diff
23 lines
795 B
Diff
From: Felix Fietkau <nbd@nbd.name>
|
|
Subject: kernel: disable MIPS VDSO by default until the cache issues have been resolved
|
|
|
|
lede-commit: 1185e645a773c86aa88cf04d0e2911dc62eb43f5
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
arch/mips/vdso/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/arch/mips/vdso/Makefile
|
|
+++ b/arch/mips/vdso/Makefile
|
|
@@ -28,9 +28,9 @@ aflags-vdso := $(ccflags-vdso) \
|
|
ifndef CONFIG_CPU_MIPSR6
|
|
ifeq ($(call ld-ifversion, -lt, 225000000, y),y)
|
|
$(warning MIPS VDSO requires binutils >= 2.25)
|
|
- obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
- ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
|
|
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
|
|
endif
|
|
|
|
# VDSO linker flags.
|