e553dfc356
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
20 lines
744 B
Diff
20 lines
744 B
Diff
Index: linux-3.14.18/drivers/reset/Kconfig
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/reset/Kconfig
|
|
+++ linux-3.14.18/drivers/reset/Kconfig
|
|
@@ -11,3 +11,7 @@ menuconfig RESET_CONTROLLER
|
|
via GPIOs or SoC-internal reset controller modules.
|
|
|
|
If unsure, say no.
|
|
+
|
|
+config RESET_CONTROLLER_OXNAS
|
|
+ bool
|
|
+ select RESET_CONTROLLER
|
|
Index: linux-3.14.18/drivers/reset/Makefile
|
|
===================================================================
|
|
--- linux-3.14.18.orig/drivers/reset/Makefile
|
|
+++ linux-3.14.18/drivers/reset/Makefile
|
|
@@ -1,2 +1,3 @@
|
|
obj-$(CONFIG_RESET_CONTROLLER) += core.o
|
|
+obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
|
|
obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o
|