72b58f2eb1
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
16 lines
663 B
Diff
16 lines
663 B
Diff
Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
|
|
===================================================================
|
|
--- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
|
|
+++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
|
|
@@ -352,7 +352,10 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
|
|
orion5x-lacie-ethernet-disk-mini-v2.dtb \
|
|
orion5x-maxtor-shared-storage-2.dtb \
|
|
orion5x-rd88f5182-nas.dtb
|
|
-dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
|
|
+dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb \
|
|
+ ox820-pogoplug-v3.dtb \
|
|
+ ox820-stg212.dtb \
|
|
+ ox820-kd20.dtb
|
|
dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
|
|
dtb-$(CONFIG_ARCH_QCOM) += \
|
|
qcom-apq8064-cm-qs600.dtb \
|