fce21ae4cc
Right now all brcm2708 patches are extracted from the non-mainline raspberrypi/linux git tree. Many of them are hacks and/or are unneeded in LEDE. Raspberry Pi is getting better and better mainline support so it would be nice to finally start maintaining patches in a cleaner way: 1) Backport patches accepted in upstream tree 2) Start using upstream drivers 3) Pick only these patches that are needed for more complete support Handling above tasks requires grouping patches - ideally using the same prefixes as generic ones. It means we should rename existing patches to use some high prefix. This will allow e.g. use 0xx for backported code. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Florian Fainelli <f.fainelli@gmail.com> Acked-by: Stijn Tintel <stijn@linux-ipv6.be>
56 lines
1.6 KiB
Diff
56 lines
1.6 KiB
Diff
From b76839857c9b553f52f8d14cf54a22579b362db9 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Wed, 11 Jan 2017 13:01:21 +0000
|
|
Subject: [PATCH] BCM270X_DT: Add pi3-disable-wifi overlay
|
|
|
|
pi3-disable-wifi is a minimal overlay to disable the onboard WiFi.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 ++++++
|
|
arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts | 13 +++++++++++++
|
|
3 files changed, 20 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -51,6 +51,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
mz61581.dtbo \
|
|
pi3-act-led.dtbo \
|
|
pi3-disable-bt.dtbo \
|
|
+ pi3-disable-wifi.dtbo \
|
|
pi3-miniuart-bt.dtbo \
|
|
piscreen.dtbo \
|
|
piscreen2r.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -800,6 +800,12 @@ Load: dtoverlay=pi3-disable-bt
|
|
Params: <None>
|
|
|
|
|
|
+Name: pi3-disable-wifi
|
|
+Info: Disable Pi3 onboard WiFi
|
|
+Load: dtoverlay=pi3-disable-wifi
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: pi3-miniuart-bt
|
|
Info: Switch Pi3 Bluetooth function to use the mini-UART (ttyS0) and restore
|
|
UART0/ttyAMA0 over GPIOs 14 & 15. Note that this may reduce the maximum
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts
|
|
@@ -0,0 +1,13 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&mmc>;
|
|
+ __overlay__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+};
|