0485747912
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43557
16 lines
605 B
Diff
16 lines
605 B
Diff
Use the cross toolchain objdump command instead of assuming that the host
|
|
toolchain has it.
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|
|
|
--- a/arch/x86/boot/compressed/Makefile
|
|
+++ b/arch/x86/boot/compressed/Makefile
|
|
@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
|
|
suffix-$(CONFIG_KERNEL_LZO) := lzo
|
|
suffix-$(CONFIG_KERNEL_LZ4) := lz4
|
|
|
|
-RUN_SIZE = $(shell objdump -h vmlinux | \
|
|
+RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
|
|
perl $(srctree)/arch/x86/tools/calc_run_size.pl)
|
|
quiet_cmd_mkpiggy = MKPIGGY $@
|
|
cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
|