139f99c058
Changes compared to GCC 7.x 001-revert_register_mode_search.patch dropped The underlying issue is described at the end of https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58139 It is fixed by the upstream commit:3fa2798aa8
020-PR-libstdc-81797-Add-.NOTPARALLEL-to-include-Makefil.patch dropped due to already upstream 100-PR-rtl-optimization-83496.patch dropped due to already upstream 910-mbsd_multi.patch modified to fix ambiguous overloaded inform() call error gcc/input.h header: define UNKNOWN_LOCATION ((source_location) 0) - inform (0, "someone does not honour COPTS correctly, passed %d times", - honour_copts); + inform (UNKNOWN_LOCATION, "someone does not honour COPTS correctly, passed %d times", + honour_copts); 940-no-clobber-stamp-bits.patch dropped due to fixed upstream by another way upstream commit:87b2d547f8
950-cpp_file_path_translation.patch dropped, Both -fmacro-prefix-map and -ffile-prefix-map are added to gcc 8.1.0, if I understand it correctly, we should use -fmacro-prefix-map usage: -fmacro-prefix-map=@var{old}=@var{new} upstream commit:859b51f836
-iremap exists as a flag for a long time, for backward compatibility, I think we should keep the variable name unchanged but change its value in rules.mk for gcc 8.x and higher. Compile and run tested on x86_64 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
22 lines
704 B
Diff
22 lines
704 B
Diff
commit 64661de100da1ec1061ef3e5e400285dce115e6b
|
|
Author: Felix Fietkau <nbd@openwrt.org>
|
|
Date: Sun May 10 13:16:35 2015 +0000
|
|
|
|
gcc: add some size optimization patches
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
|
|
|
SVN-Revision: 45664
|
|
|
|
--- a/libgcc/config/t-libunwind
|
|
+++ b/libgcc/config/t-libunwind
|
|
@@ -2,8 +2,7 @@
|
|
|
|
HOST_LIBGCC2_CFLAGS += -DUSE_GAS_SYMVER
|
|
|
|
-LIB2ADDEH = $(srcdir)/unwind-sjlj.c $(srcdir)/unwind-c.c \
|
|
- $(srcdir)/unwind-compat.c $(srcdir)/unwind-dw2-fde-compat.c
|
|
+LIB2ADDEH = $(srcdir)/unwind-sjlj.c $(srcdir)/unwind-c.c
|
|
LIB2ADDEHSTATIC = $(srcdir)/unwind-sjlj.c $(srcdir)/unwind-c.c
|
|
|
|
# Override the default value from t-slibgcc-elf-ver and mention -lunwind
|