139f99c058
Changes compared to GCC 7.x 001-revert_register_mode_search.patch dropped The underlying issue is described at the end of https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58139 It is fixed by the upstream commit:3fa2798aa8
020-PR-libstdc-81797-Add-.NOTPARALLEL-to-include-Makefil.patch dropped due to already upstream 100-PR-rtl-optimization-83496.patch dropped due to already upstream 910-mbsd_multi.patch modified to fix ambiguous overloaded inform() call error gcc/input.h header: define UNKNOWN_LOCATION ((source_location) 0) - inform (0, "someone does not honour COPTS correctly, passed %d times", - honour_copts); + inform (UNKNOWN_LOCATION, "someone does not honour COPTS correctly, passed %d times", + honour_copts); 940-no-clobber-stamp-bits.patch dropped due to fixed upstream by another way upstream commit:87b2d547f8
950-cpp_file_path_translation.patch dropped, Both -fmacro-prefix-map and -ffile-prefix-map are added to gcc 8.1.0, if I understand it correctly, we should use -fmacro-prefix-map usage: -fmacro-prefix-map=@var{old}=@var{new} upstream commit:859b51f836
-iremap exists as a flag for a long time, for backward compatibility, I think we should keep the variable name unchanged but change its value in rules.mk for gcc 8.x and higher. Compile and run tested on x86_64 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
35 lines
968 B
Diff
35 lines
968 B
Diff
commit 098bd91f5eae625c7d2ee621e10930fc4434e5e2
|
|
Author: Luka Perkov <luka@openwrt.org>
|
|
Date: Tue Feb 26 16:16:33 2013 +0000
|
|
|
|
gcc: don't build documentation
|
|
|
|
This closes #13039.
|
|
|
|
Signed-off-by: Luka Perkov <luka@openwrt.org>
|
|
|
|
SVN-Revision: 35807
|
|
|
|
--- a/gcc/Makefile.in
|
|
+++ b/gcc/Makefile.in
|
|
@@ -3203,18 +3203,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
|
doc/gccint.info: $(TEXI_GCCINT_FILES)
|
|
doc/cppinternals.info: $(TEXI_CPPINT_FILES)
|
|
|
|
-doc/%.info: %.texi
|
|
- if [ x$(BUILD_INFO) = xinfo ]; then \
|
|
- $(MAKEINFO) $(MAKEINFOFLAGS) -I . -I $(gcc_docdir) \
|
|
- -I $(gcc_docdir)/include -o $@ $<; \
|
|
- fi
|
|
+doc/%.info:
|
|
|
|
# Duplicate entry to handle renaming of gccinstall.info
|
|
-doc/gccinstall.info: $(TEXI_GCCINSTALL_FILES)
|
|
- if [ x$(BUILD_INFO) = xinfo ]; then \
|
|
- $(MAKEINFO) $(MAKEINFOFLAGS) -I $(gcc_docdir) \
|
|
- -I $(gcc_docdir)/include -o $@ $<; \
|
|
- fi
|
|
+doc/gccinstall.info:
|
|
|
|
doc/cpp.dvi: $(TEXI_CPP_FILES)
|
|
doc/gcc.dvi: $(TEXI_GCC_FILES)
|