e72b2464b1
This bumps the 4.4. kernel in master to 4.4.119. Includes more Meltdown & Spectre mitigation. * Refresh patches. * Refresh x86/config for RETPOLINE. * Deleted 8049-PCI-layerscape-Add-fsl-ls2085a-pcie-compatible-ID.patch (accepted upstream) * Deleted 8050-PCI-layerscape-Fix-MSG-TLP-drop-setting.patch (accepted upstream) * Deleted 650-pppoe_header_pad.patch (does not apply anymore (code was replaced)). Bumps from 4.4.112 to 4.4.115 were handled by Kevin Darbyshire-Bryant. Compile-tested on: ar71xx & oxnas. Signed-off-by: Stijn Segers <foss@volatilesystems.org> Tested-by: Rosen Penev <rosenp@gmail.com>
26 lines
847 B
Diff
26 lines
847 B
Diff
--- a/drivers/usb/host/Kconfig
|
|
+++ b/drivers/usb/host/Kconfig
|
|
@@ -315,6 +315,13 @@ config USB_OCTEON_EHCI
|
|
USB 2.0 device support. All CN6XXX based chips with USB are
|
|
supported.
|
|
|
|
+config USB_EHCI_OXNAS
|
|
+ tristate "OXNAS EHCI Module"
|
|
+ depends on USB_EHCI_HCD && ARCH_OXNAS
|
|
+ select USB_EHCI_ROOT_HUB_TT
|
|
+ ---help---
|
|
+ Enable support for the OX820 SOC's on-chip EHCI controller.
|
|
+
|
|
endif # USB_EHCI_HCD
|
|
|
|
config USB_OXU210HP_HCD
|
|
--- a/drivers/usb/host/Makefile
|
|
+++ b/drivers/usb/host/Makefile
|
|
@@ -41,6 +41,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
|
|
obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
|
|
obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
|
|
obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
|
|
+obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
|
|
|
|
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
|
|
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
|