20402106a3
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
261 lines
8.1 KiB
Diff
261 lines
8.1 KiB
Diff
From 6fa4c2110478a814a9dd44d64522e7a81a1a2793 Mon Sep 17 00:00:00 2001
|
|
From: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
Date: Sat, 2 Jul 2016 16:26:19 +0100
|
|
Subject: [PATCH 423/423] Add support for Dion Audio LOCO DAC-AMP HAT
|
|
|
|
Using dedicated machine driver and pcm5102a codec driver.
|
|
|
|
Signed-off-by: DigitalDreamtime <clive.messer@digitaldreamtime.co.uk>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 +
|
|
.../boot/dts/overlays/dionaudio-loco-overlay.dts | 39 +++++++
|
|
arch/arm/configs/bcm2709_defconfig | 1 +
|
|
arch/arm/configs/bcmrpi_defconfig | 1 +
|
|
sound/soc/bcm/Kconfig | 7 ++
|
|
sound/soc/bcm/Makefile | 3 +-
|
|
sound/soc/bcm/dionaudio_loco.c | 121 +++++++++++++++++++++
|
|
8 files changed, 178 insertions(+), 1 deletion(-)
|
|
create mode 100644 arch/arm/boot/dts/overlays/dionaudio-loco-overlay.dts
|
|
create mode 100644 sound/soc/bcm/dionaudio_loco.c
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -20,6 +20,7 @@ dtbo-$(RPI_DT_OVERLAYS) += at86rf233.dtb
|
|
dtbo-$(RPI_DT_OVERLAYS) += audioinjector-wm8731-audio.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += bmp085_i2c-sensor.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dht11.dtbo
|
|
+dtbo-$(RPI_DT_OVERLAYS) += dionaudio-loco.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dpi24.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dwc-otg.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dwc2.dtbo
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -268,6 +268,12 @@ Params: gpiopin GPIO con
|
|
(default 4)
|
|
|
|
|
|
+Name: dionaudio-loco
|
|
+Info: Configures the Dion Audio LOCO DAC-AMP
|
|
+Load: dtoverlay=dionaudio-loco
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: dpi24
|
|
Info: Overlay for a generic 24-bit DPI display
|
|
This uses GPIOs 0-27 (so no I2C, uart etc.), and activates the output
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/dionaudio-loco-overlay.dts
|
|
@@ -0,0 +1,39 @@
|
|
+// Definitions for Dion Audio LOCO DAC-AMP
|
|
+
|
|
+/*
|
|
+ * PCM5242 DAC (in hardware mode) and TPA3118 AMP.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&i2s>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ pcm5102a-codec {
|
|
+ #sound-dai-cells = <0>;
|
|
+ compatible = "ti,pcm5102a";
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&sound>;
|
|
+ __overlay__ {
|
|
+ compatible = "dionaudio,loco-pcm5242-tpa3118";
|
|
+ i2s-controller = <&i2s>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+};
|
|
--- a/arch/arm/configs/bcm2709_defconfig
|
|
+++ b/arch/arm/configs/bcm2709_defconfig
|
|
@@ -870,6 +870,7 @@ CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
|
|
CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
|
|
CONFIG_SND_DIGIDAC1_SOUNDCARD=m
|
|
CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
|
|
+CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/arch/arm/configs/bcmrpi_defconfig
|
|
+++ b/arch/arm/configs/bcmrpi_defconfig
|
|
@@ -862,6 +862,7 @@ CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
|
|
CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD=m
|
|
CONFIG_SND_DIGIDAC1_SOUNDCARD=m
|
|
CONFIG_SND_BCM2708_SOC_ADAU1977_ADC=m
|
|
+CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -107,3 +107,10 @@ config SND_DIGIDAC1_SOUNDCARD
|
|
select SND_SOC_WM8741
|
|
help
|
|
Say Y or M if you want to add support for Red Rocks Audio DigiDAC1 board.
|
|
+
|
|
+config SND_BCM2708_SOC_DIONAUDIO_LOCO
|
|
+ tristate "Support for Dion Audio LOCO DAC-AMP"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_PCM5102a
|
|
+ help
|
|
+ Say Y or M if you want to add support for Dion Audio LOCO.
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -18,6 +18,7 @@ snd-soc-iqaudio-digi-objs := iqaudio_dig
|
|
snd-soc-raspidac3-objs := raspidac3.o
|
|
snd-soc-audioinjector-pi-soundcard-objs := audioinjector-pi-soundcard.o
|
|
snd-soc-digidac1-soundcard-objs := digidac1-soundcard.o
|
|
+snd-soc-dionaudio-loco-objs := dionaudio_loco.o
|
|
|
|
obj-$(CONFIG_SND_BCM2708_SOC_ADAU1977_ADC) += snd-soc-adau1977-adc.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
|
|
@@ -33,4 +34,4 @@ obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DIG
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RASPIDAC3) += snd-soc-raspidac3.o
|
|
obj-$(CONFIG_SND_AUDIOINJECTOR_PI_SOUNDCARD) += snd-soc-audioinjector-pi-soundcard.o
|
|
obj-$(CONFIG_SND_DIGIDAC1_SOUNDCARD) += snd-soc-digidac1-soundcard.o
|
|
-
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_DIONAUDIO_LOCO) += snd-soc-dionaudio-loco.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/dionaudio_loco.c
|
|
@@ -0,0 +1,121 @@
|
|
+/*
|
|
+ * ASoC Driver for Dion Audio LOCO DAC-AMP
|
|
+ *
|
|
+ * Author: Miquel Blauw <info@dionaudio.nl>
|
|
+ * Copyright 2016
|
|
+ *
|
|
+ * Based on the software of the RPi-DAC writen by Florian Meier
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_hw_params(
|
|
+ struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+
|
|
+ unsigned int sample_bits =
|
|
+ snd_pcm_format_physical_width(params_format(params));
|
|
+
|
|
+ return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_dionaudio_loco_ops = {
|
|
+ .hw_params = snd_rpi_dionaudio_loco_hw_params,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_dionaudio_loco_dai[] = {
|
|
+{
|
|
+ .name = "DionAudio LOCO",
|
|
+ .stream_name = "DionAudio LOCO DAC-AMP",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "pcm5102a-hifi",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "pcm5102a-codec",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S |
|
|
+ SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBS_CFS,
|
|
+ .ops = &snd_rpi_dionaudio_loco_ops,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_dionaudio_loco = {
|
|
+ .name = "snd_rpi_dionaudio_loco",
|
|
+ .dai_link = snd_rpi_dionaudio_loco_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_dionaudio_loco_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_probe(struct platform_device *pdev)
|
|
+{
|
|
+ struct device_node *np;
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_rpi_dionaudio_loco.dev = &pdev->dev;
|
|
+
|
|
+ np = pdev->dev.of_node;
|
|
+ if (np) {
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_dionaudio_loco_dai[0];
|
|
+ struct device_node *i2s_np;
|
|
+
|
|
+ i2s_np = of_parse_phandle(np, "i2s-controller", 0);
|
|
+ if (i2s_np) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_np;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_np;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_rpi_dionaudio_loco);
|
|
+ if (ret)
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n",
|
|
+ ret);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int snd_rpi_dionaudio_loco_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_rpi_dionaudio_loco);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_rpi_dionaudio_loco_of_match[] = {
|
|
+ { .compatible = "dionaudio,loco-pcm5242-tpa3118", },
|
|
+ { /* sentinel */ },
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, snd_rpi_dionaudio_loco_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_dionaudio_loco_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-dionaudio-loco",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_rpi_dionaudio_loco_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_dionaudio_loco_probe,
|
|
+ .remove = snd_rpi_dionaudio_loco_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_dionaudio_loco_driver);
|
|
+
|
|
+MODULE_AUTHOR("Miquel Blauw <info@dionaudio.nl>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for DionAudio LOCO");
|
|
+MODULE_LICENSE("GPL v2");
|