openwrtv4/target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch
Imre Kaloz 3d4466cfd8 add preliminary 2.6.32 support
SVN-Revision: 18283
2009-11-03 10:49:27 +00:00

25 lines
540 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -810,6 +810,8 @@ config CRYPTO_ANSI_CPRNG
ANSI X9.31 A.2.4. Not this option must be enabled if CRYPTO_FIPS
is selected
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o