openwrtv4/target/linux/ar71xx/patches-3.10/713-MIPS-ath79-add-RBSXTLite-support.patch
John Crispin 3519322e62 ar71xx: Add support for MikroTik RouterBOARD SXT Lite
This patch adds support for the MikroTik RouterBOARD SXT Lite.

The new RB911L series is also supported as a result.

v2 of this patch fixes the wmac offset to match what is on the sticker.
v3 refreshes the patch against r41148 and defines the power led as the status led in diag.sh
v4 refreshes the patch against r41353 and fixes the patch path issue to make git am work correctly
v5 selects the kernel config option in the mikrotik profile rather than in the main ar71xx config

Signed-off-by: Matthew Reeve <mreeve@tenxnetworks.com>
Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 41450
2014-07-01 13:38:30 +00:00

38 lines
1.7 KiB
Diff

--- a/arch/mips/ath79/Kconfig 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/Kconfig 2014-05-21 20:28:20.489109814 +0000
@@ -462,6 +462,14 @@ config ATH79_MACH_RB2011
select ATH79_ROUTERBOOT
select RLE_DECOMPRESS
+config ATH79_MACH_RBSXTLITE
+ bool "MikroTik RouterBOARD SXT Lite"
+ select SOC_AR934x
+ select ATH79_DEV_ETH
+ select ATH79_DEV_NFC
+ select ATH79_DEV_WMAC
+ select ATH79_ROUTERBOOT
+
config ATH79_MACH_WNDAP360
bool "NETGEAR WNDAP360 board support"
select SOC_AR71XX
--- a/arch/mips/ath79/machtypes.h 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/machtypes.h 2014-05-21 20:30:04.829111865 +0000
@@ -93,6 +93,8 @@ enum ath79_mach_type {
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
ATH79_MACH_RB_2011US, /* Mikrotik RouterBOARD 2011UAS */
+ ATH79_MACH_RB_SXTLITE2ND, /* Mikrotik RouterBOARD SXT Lite 2nD */
+ ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
--- a/arch/mips/ath79/Makefile 2014-05-21 20:25:24.801106234 +0000
+++ b/arch/mips/ath79/Makefile 2014-05-21 20:31:37.169113830 +0000
@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_RB750) += mach-
obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
+obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o