f704b643b9
Runtime tested on lantiq. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
26 lines
941 B
Diff
26 lines
941 B
Diff
From 107c0964cb8db7ca28ac5199426414fdab3c274d Mon Sep 17 00:00:00 2001
|
|
From: "Alexandros C. Couloumbis" <alex@ozo.com>
|
|
Date: Fri, 7 Jul 2017 17:14:51 +0200
|
|
Subject: hack: arch: powerpc: drop register save/restore library from modules
|
|
|
|
Upstream GCC uses a libgcc function for saving/restoring registers. This
|
|
makes the code bigger, and upstream kernels need to carry that function
|
|
for every single kernel module. Our GCC is patched to avoid those
|
|
references, so we can drop the extra bloat for modules.
|
|
|
|
lede-commit: e8e1084654f50904e6bf77b70b2de3f137d7b3ec
|
|
Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|
---
|
|
arch/powerpc/Makefile | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -188,7 +188,6 @@ else
|
|
CHECKFLAGS += -D__LITTLE_ENDIAN__
|
|
endif
|
|
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
|
|
ifeq ($(CONFIG_476FPE_ERR46),y)
|
|
KBUILD_LDFLAGS_MODULE += --ppc476-workaround \
|