2b1c6b21b5
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Also adds support for Raspberry Pi Compute Module 3 (untested). Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
74 lines
2.2 KiB
Diff
74 lines
2.2 KiB
Diff
From f88c6236440972207406742d87692859b4f15612 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Tue, 5 Apr 2016 13:01:54 +0100
|
|
Subject: [PATCH] BCM270X_DT: Add dpi24 overlay
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 8 +++++++
|
|
arch/arm/boot/dts/overlays/dpi24-overlay.dts | 31 ++++++++++++++++++++++++++++
|
|
3 files changed, 40 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/dpi24-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -15,6 +15,7 @@ endif
|
|
dtbo-$(RPI_DT_OVERLAYS) += ads7846.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += at86rf233.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += bmp085_i2c-sensor.dtbo
|
|
+dtbo-$(RPI_DT_OVERLAYS) += dpi24.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dwc2.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dwc-otg.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += dht11.dtbo
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -213,6 +213,14 @@ Params: gpiopin GPIO con
|
|
(default 4)
|
|
|
|
|
|
+Name: dpi24
|
|
+Info: Overlay for a generic 24-bit DPI display
|
|
+ This uses GPIOs 0-27 (so no I2C, uart etc.), and activates the output
|
|
+ 2-3 seconds after the kernel has started.
|
|
+Load: dtoverlay=dpi24
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: dwc-otg
|
|
Info: Selects the dwc_otg USB controller driver which has fiq support. This
|
|
is the default on all except the Pi Zero which defaults to dwc2.
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/dpi24-overlay.dts
|
|
@@ -0,0 +1,31 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ // There is no DPI driver module, but we need a platform device
|
|
+ // node (that doesn't already use pinctrl) to hang the pinctrl
|
|
+ // reference on - leds will do
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&leds>;
|
|
+ __overlay__ {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&dpi24_pins>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ dpi24_pins: dpi24_pins {
|
|
+ brcm,pins = <0 1 2 3 4 5 6 7 8 9 10 11
|
|
+ 12 13 14 15 16 17 18 19 20
|
|
+ 21 22 23 24 25 26 27>;
|
|
+ brcm,function = <6>; /* alt2 */
|
|
+ brcm,pull = <0>; /* no pull */
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|