bf28fb50bf
As usual, this patches were taken (and rebased) from https://github.com/raspberrypi/linux/commits/rpi-4.1.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47258
106 lines
3.2 KiB
Diff
106 lines
3.2 KiB
Diff
From a4c686a6a8cc5938de37451714add5ea872f67c2 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Fri, 6 Feb 2015 13:50:57 +0000
|
|
Subject: [PATCH 053/203] BCM270x_DT: Add pwr_led, and the required "input"
|
|
trigger
|
|
|
|
The "input" trigger makes the associated GPIO an input. This is to support
|
|
the Raspberry Pi PWR LED, which is driven by external hardware in normal use.
|
|
|
|
N.B. pwr_led is not available on Model A or B boards.
|
|
---
|
|
drivers/leds/trigger/Kconfig | 7 ++++
|
|
drivers/leds/trigger/Makefile | 1 +
|
|
drivers/leds/trigger/ledtrig-input.c | 65 ++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 73 insertions(+)
|
|
create mode 100644 drivers/leds/trigger/ledtrig-input.c
|
|
|
|
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -126,4 +126,11 @@ config LEDS_TRIGGER_USBDEV
|
|
This allows LEDs to be controlled by the presence/activity of
|
|
an USB device. If unsure, say N.
|
|
|
|
+config LEDS_TRIGGER_INPUT
|
|
+ tristate "LED Input Trigger"
|
|
+ depends on LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows the GPIOs assigned to be LEDs to be initialised to inputs.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--- a/drivers/leds/trigger/Makefile
|
|
+++ b/drivers/leds/trigger/Makefile
|
|
@@ -8,3 +8,4 @@ obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtr
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_CAMERA) += ledtrig-camera.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_INPUT) += ledtrig-input.o
|
|
--- /dev/null
|
|
+++ b/drivers/leds/trigger/ledtrig-input.c
|
|
@@ -0,0 +1,65 @@
|
|
+/*
|
|
+ * Set LED GPIO to Input "Trigger"
|
|
+ *
|
|
+ * Copyright 2015 Phil Elwell <phil@raspberrypi.org>
|
|
+ *
|
|
+ * Based on Nick Forbes's ledtrig-default-on.c.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ *
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/leds.h>
|
|
+#include <linux/gpio.h>
|
|
+#include "../leds.h"
|
|
+
|
|
+/* This is a hack to get at the private 'gpio' member */
|
|
+
|
|
+struct gpio_led_data {
|
|
+ struct led_classdev cdev;
|
|
+ unsigned gpio;
|
|
+};
|
|
+
|
|
+static void input_trig_activate(struct led_classdev *led_cdev)
|
|
+{
|
|
+ struct gpio_led_data *led_dat =
|
|
+ container_of(led_cdev, struct gpio_led_data, cdev);
|
|
+ if (gpio_is_valid(led_dat->gpio))
|
|
+ gpio_direction_input(led_dat->gpio);
|
|
+}
|
|
+
|
|
+static void input_trig_deactivate(struct led_classdev *led_cdev)
|
|
+{
|
|
+ struct gpio_led_data *led_dat =
|
|
+ container_of(led_cdev, struct gpio_led_data, cdev);
|
|
+ if (gpio_is_valid(led_dat->gpio))
|
|
+ gpio_direction_output(led_dat->gpio, 0);
|
|
+}
|
|
+
|
|
+static struct led_trigger input_led_trigger = {
|
|
+ .name = "input",
|
|
+ .activate = input_trig_activate,
|
|
+ .deactivate = input_trig_deactivate,
|
|
+};
|
|
+
|
|
+static int __init input_trig_init(void)
|
|
+{
|
|
+ return led_trigger_register(&input_led_trigger);
|
|
+}
|
|
+
|
|
+static void __exit input_trig_exit(void)
|
|
+{
|
|
+ led_trigger_unregister(&input_led_trigger);
|
|
+}
|
|
+
|
|
+module_init(input_trig_init);
|
|
+module_exit(input_trig_exit);
|
|
+
|
|
+MODULE_AUTHOR("Phil Elwell <phil@raspberrypi.org>");
|
|
+MODULE_DESCRIPTION("Set LED GPIO to Input \"trigger\"");
|
|
+MODULE_LICENSE("GPL");
|