7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
26 lines
912 B
Diff
26 lines
912 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -761,6 +761,13 @@ config SPI_TLE62X0
|
|
sysfs interface, with each line presented as a kind of GPIO
|
|
exposing both switch control and diagnostic feedback.
|
|
|
|
+config SPI_RB4XX_CPLD
|
|
+ tristate "MikroTik RB4XX CPLD driver"
|
|
+ depends on ATH79_MACH_RB4XX
|
|
+ help
|
|
+ SPI driver for the Xilinx CPLD chip present on the
|
|
+ MikroTik RB4xx boards.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -73,6 +73,7 @@ spi-pxa2xx-platform-objs := spi-pxa2xx.
|
|
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
|
|
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
|
|
obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
|
|
+obj-$(CONFIG_SPI_RB4XX_CPLD) += spi-rb4xx-cpld.o
|
|
obj-$(CONFIG_SPI_QUP) += spi-qup.o
|
|
obj-$(CONFIG_SPI_ROCKCHIP) += spi-rockchip.o
|
|
obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
|