b13e981d72
This activates support for fit images and some other new mkimage features. Some of the patches were applied upstream and could be removed. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
14 lines
614 B
Diff
14 lines
614 B
Diff
OpenWrt links the libressl statically against mkimage, make sure all the
|
|
needed dependencies are added too.
|
|
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -145,7 +145,7 @@ endif
|
|
# MXSImage needs LibSSL
|
|
ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
|
|
HOSTLOADLIBES_mkimage += \
|
|
- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
|
+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
|
|
|
|
# OS X deprecate openssl in favour of CommonCrypto, supress deprecation
|
|
# warnings on those systems
|