b9a35920bf
This will avoid the usage of swig. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
96 lines
3.1 KiB
Diff
96 lines
3.1 KiB
Diff
From eed65e5c25cbc4b6e893f140e9d7898f4624c114 Mon Sep 17 00:00:00 2001
|
|
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
Date: Wed, 19 Jul 2017 23:12:38 +0200
|
|
Subject: [PATCH 210/213] Revert "fdt: Makefile: Build python libfdt library if
|
|
needed"
|
|
|
|
This reverts commit e38ffc42674fedc750ca895046be0bd983b56dd5.
|
|
---
|
|
Makefile | 17 ++---------------
|
|
scripts/Makefile.spl | 17 ++++-------------
|
|
2 files changed, 6 insertions(+), 28 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 119ad49eec..071efa8926 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1116,7 +1116,7 @@ cmd_ldr = $(LD) $(LDFLAGS_$(@F)) \
|
|
|
|
u-boot.rom: u-boot-x86-16bit.bin u-boot.bin \
|
|
$(if $(CONFIG_SPL_X86_16BIT_INIT),spl/u-boot-spl.bin) \
|
|
- $(if $(CONFIG_HAVE_REFCODE),refcode.bin) checkbinman FORCE
|
|
+ $(if $(CONFIG_HAVE_REFCODE),refcode.bin) FORCE
|
|
$(call if_changed,binman)
|
|
|
|
OBJCOPYFLAGS_u-boot-x86-16bit.bin := -O binary -j .start16 -j .resetvec
|
|
@@ -1125,8 +1125,7 @@ u-boot-x86-16bit.bin: u-boot FORCE
|
|
endif
|
|
|
|
ifneq ($(CONFIG_ARCH_SUNXI),)
|
|
-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb \
|
|
- checkbinman FORCE
|
|
+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
|
|
$(call if_changed,binman)
|
|
endif
|
|
|
|
@@ -1355,18 +1354,6 @@ $(version_h): include/config/uboot.release FORCE
|
|
$(timestamp_h): $(srctree)/Makefile FORCE
|
|
$(call filechk,timestamp.h)
|
|
|
|
-checkbinman: tools
|
|
- @if ! ( echo 'import libfdt' | ( PYTHONPATH=tools python )); then \
|
|
- echo >&2; \
|
|
- echo >&2 '*** binman needs the Python libfdt library.'; \
|
|
- echo >&2 '*** Either install it on your system, or try:'; \
|
|
- echo >&2 '***'; \
|
|
- echo >&2 '*** sudo apt-get install swig libpython-dev'; \
|
|
- echo >&2 '***'; \
|
|
- echo >&2 '*** to have U-Boot build its own version.'; \
|
|
- false; \
|
|
- fi
|
|
-
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds = LDS $@
|
|
cmd_cpp_lds = $(CPP) -Wp,-MD,$(depfile) $(cpp_flags) $(LDPPFLAGS) \
|
|
diff --git a/scripts/Makefile.spl b/scripts/Makefile.spl
|
|
index ac3c2c7f13..135706f21d 100644
|
|
--- a/scripts/Makefile.spl
|
|
+++ b/scripts/Makefile.spl
|
|
@@ -257,12 +257,14 @@ PHONY += dts_dir
|
|
dts_dir:
|
|
$(shell [ -d $(obj)/dts ] || mkdir -p $(obj)/dts)
|
|
|
|
-include/generated/dt-structs.h: $(obj)/$(SPL_BIN).dtb dts_dir checkdtoc
|
|
+include/generated/dt-structs.h: $(obj)/$(SPL_BIN).dtb dts_dir dtoc
|
|
$(call if_changed,dtoch)
|
|
|
|
-$(obj)/dts/dt-platdata.c: $(obj)/$(SPL_BIN).dtb dts_dir checkdtoc
|
|
+$(obj)/dts/dt-platdata.c: $(obj)/$(SPL_BIN).dtb dts_dir dtoc
|
|
$(call if_changed,dtocc)
|
|
|
|
+dtoc: #$(objtree)/tools/_libfdt.so
|
|
+
|
|
ifdef CONFIG_SAMSUNG
|
|
ifdef CONFIG_VAR_SIZE_SPL
|
|
VAR_SIZE_PARAM = --vs
|
|
@@ -355,17 +357,6 @@ ifneq ($(cmd_files),)
|
|
include $(cmd_files)
|
|
endif
|
|
|
|
-checkdtoc: tools
|
|
- @if ! ( echo 'import libfdt' | ( PYTHONPATH=tools python )); then \
|
|
- echo '*** dtoc needs the Python libfdt library. Either '; \
|
|
- echo '*** install it on your system, or try:'; \
|
|
- echo '***'; \
|
|
- echo '*** sudo apt-get install swig libpython-dev'; \
|
|
- echo '***'; \
|
|
- echo '*** to have U-Boot build its own version.'; \
|
|
- false; \
|
|
- fi
|
|
-
|
|
PHONY += FORCE
|
|
FORCE:
|
|
|
|
--
|
|
2.11.0
|
|
|