a33a567b39
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 46540
277 lines
7.5 KiB
Diff
277 lines
7.5 KiB
Diff
diff -ruN old/arch/arm/dts/Makefile new/arch/arm/dts/Makefile
|
|
--- old/arch/arm/dts/Makefile 2015-07-14 19:32:21.000000000 +0200
|
|
+++ new/arch/arm/dts/Makefile 2015-07-31 23:23:33.518767858 +0200
|
|
@@ -107,6 +107,7 @@
|
|
sun7i-a20-cubietruck.dtb \
|
|
sun7i-a20-hummingbird.dtb \
|
|
sun7i-a20-i12-tvbox.dtb \
|
|
+ sun7i-a20-lamobo-r1.dtb \
|
|
sun7i-a20-m3.dtb \
|
|
sun7i-a20-m5.dtb \
|
|
sun7i-a20-mk808c.dtb \
|
|
diff -ruN old/arch/arm/dts/sun7i-a20-lamobo-r1.dts new/arch/arm/dts/sun7i-a20-lamobo-r1.dts
|
|
--- old/arch/arm/dts/sun7i-a20-lamobo-r1.dts 1970-01-01 01:00:00.000000000 +0100
|
|
+++ new/arch/arm/dts/sun7i-a20-lamobo-r1.dts 2015-07-31 23:19:30.811206714 +0200
|
|
@@ -0,0 +1,239 @@
|
|
+/*
|
|
+ * Copyright 2014 Hans de Goede <hdegoede@redhat.com>
|
|
+ *
|
|
+ * Hans de Goede <hdegoede@redhat.com>
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public
|
|
+ * License along with this file; if not, write to the Free
|
|
+ * Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
|
|
+ * MA 02110-1301 USA
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "sun7i-a20.dtsi"
|
|
+#include "sunxi-common-regulators.dtsi"
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/interrupt-controller/irq.h>
|
|
+#include <dt-bindings/pinctrl/sun4i-a10.h>
|
|
+
|
|
+/ {
|
|
+ model = "Lamobo R1";
|
|
+ compatible = "lamobo,lamobo-r1", "allwinner,sun7i-a20";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &uart0;
|
|
+ serial1 = &uart3;
|
|
+ serial2 = &uart7;
|
|
+ };
|
|
+
|
|
+ soc@01c00000 {
|
|
+ spi0: spi@01c05000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&spi0_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ mmc0: mmc@01c0f000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&mmc0_pins_a>, <&mmc0_cd_pin_bananapi>;
|
|
+ vmmc-supply = <®_vcc3v3>;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 7 10 0>; /* PH10 */
|
|
+ cd-inverted;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ usbphy: phy@01c13400 {
|
|
+ usb1_vbus-supply = <®_usb1_vbus>;
|
|
+ usb2_vbus-supply = <®_usb2_vbus>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ehci0: usb@01c14000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ohci0: usb@01c14400 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ahci: sata@01c18000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ehci1: usb@01c1c000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ ohci1: usb@01c1c400 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ pinctrl@01c20800 {
|
|
+ mmc0_cd_pin_bananapi: mmc0_cd_pin@0 {
|
|
+ allwinner,pins = "PH10";
|
|
+ allwinner,function = "gpio_in";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <1>;
|
|
+ };
|
|
+
|
|
+ gmac_power_pin_bananapi: gmac_power_pin@0 {
|
|
+ allwinner,pins = "PH23";
|
|
+ allwinner,function = "gpio_out";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <0>;
|
|
+ };
|
|
+
|
|
+ led_pins_bananapi: led_pins@0 {
|
|
+ allwinner,pins = "PH24";
|
|
+ allwinner,function = "gpio_out";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <0>;
|
|
+ };
|
|
+
|
|
+ ahci_pwr_pin_a: ahci_pwr_pin@0 {
|
|
+ allwinner,pins = "PB3";
|
|
+ allwinner,function = "gpio_out";
|
|
+ allwinner,drive = <0>;
|
|
+ allwinner,pull = <0>;
|
|
+ };
|
|
+
|
|
+ };
|
|
+
|
|
+
|
|
+ uart0: serial@01c28000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ uart3: serial@01c28c00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart3_pins_b>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ uart7: serial@01c29c00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart7_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ i2c0: i2c@01c2ac00 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c0_pins_a>;
|
|
+ status = "okay";
|
|
+
|
|
+ axp209: pmic@34 {
|
|
+ compatible = "x-powers,axp209";
|
|
+ reg = <0x34>;
|
|
+ interrupt-parent = <&nmi_intc>;
|
|
+ interrupts = <0 8>;
|
|
+
|
|
+ interrupt-controller;
|
|
+ #interrupt-cells = <1>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ i2c2: i2c@01c2b400 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&i2c2_pins_a>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ gmac: ethernet@01c50000 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&gmac_pins_rgmii_a>;
|
|
+ phy = <&phy1>;
|
|
+ phy-mode = "rgmii";
|
|
+ phy-supply = <®_gmac_3v3>;
|
|
+ status = "okay";
|
|
+
|
|
+ phy1: ethernet-phy@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&led_pins_bananapi>;
|
|
+
|
|
+ green {
|
|
+ label = "bananapi:green:usr";
|
|
+ gpios = <&pio 7 24 0>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_usb1_vbus: usb1-vbus {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ reg_usb2_vbus: usb2-vbus {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ reg_gmac_3v3: gmac-3v3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&gmac_power_pin_bananapi>;
|
|
+ regulator-name = "gmac-3v3";
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ startup-delay-us = <100000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 7 23 0>;
|
|
+ };
|
|
+
|
|
+ reg_ahci_5v: ahci-5v {
|
|
+ compatible = "regulator-fixed";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&ahci_pwr_pin_a>;
|
|
+ regulator-name = "ahci-5v";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 1 3 0>;
|
|
+ status = "okay";
|
|
+ };
|
|
+};
|
|
diff -ruN old/configs/Lamobo_R1_defconfig new/configs/Lamobo_R1_defconfig
|
|
--- old/configs/Lamobo_R1_defconfig 1970-01-01 01:00:00.000000000 +0100
|
|
+++ new/configs/Lamobo_R1_defconfig 2015-07-31 23:02:06.000000000 +0200
|
|
@@ -0,0 +1,19 @@
|
|
+CONFIG_SPL=y
|
|
+CONFIG_SYS_EXTRA_OPTIONS="AXP209_POWER,SUNXI_GMAC,RGMII,MACPWR=SUNXI_GPH(23),AHCI,USB_EHCI,SATAPWR=SUNXI_GPB(3)"
|
|
+CONFIG_DEFAULT_DEVICE_TREE="sun7i-a20-lamobo-r1"
|
|
+CONFIG_GMAC_TX_DELAY=4
|
|
+CONFIG_ARM=y
|
|
+CONFIG_ARCH_SUNXI=y
|
|
+CONFIG_MACH_SUN7I=y
|
|
+CONFIG_DRAM_CLK=432
|
|
+CONFIG_DRAM_ZQ=127
|
|
+CONFIG_DRAM_EMR1=4
|
|
+CONFIG_ETH_DESIGNWARE=y
|
|
+CONFIG_NETDEVICES=y
|
|
+CONFIG_NET=y
|
|
+# CONFIG_CMD_IMLS is not set
|
|
+# CONFIG_CMD_FLASH is not set
|
|
+# CONFIG_CMD_FPGA is not set
|
|
+CONFIG_DM_SERIAL=y
|
|
+CONFIG_USB=y
|
|
+CONFIG_DM_USB=y
|