a2a225517d
GDB 8.1.1 brings the following fixes and enhancements over GDB 8.1: * PR gdb/22824 (misleading description of new rbreak Python function in GDB 8.1 NEWS file) * PR gdb/22849 (ctrl-c doesn't work in extended-remote) * PR gdb/22907 ([Regression] gdbserver doesn't work with filename-only binaries) * PR gdb/23028 (inconsistent disassemble of vcvtpd2dq) * PR gdb/23053 (Fix -D_GLIBCXX_DEBUG gdb-add-index regression) * PR gdb/23127 ([AArch64] GDB cannot be used for debugging software that uses high Virtual Addresses) * PR server/23158 (gdbserver no longer functional on Windows) * PR breakpoints/23210 ([8.1/8.2 Regression] Bogus Breakpoint address adjusted from 0xf7fe7dd3 to 0xfffffffff7fe7dd3) Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
76 lines
2.7 KiB
Diff
76 lines
2.7 KiB
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1293,13 +1293,13 @@ if test -z "$LD"; then
|
|
fi
|
|
fi
|
|
|
|
-# Check whether -static-libstdc++ -static-libgcc is supported.
|
|
+# Check whether -static-libstdc++ is supported.
|
|
have_static_libs=no
|
|
if test "$GCC" = yes; then
|
|
saved_LDFLAGS="$LDFLAGS"
|
|
|
|
- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
|
|
- AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
|
|
+ LDFLAGS="$LDFLAGS -static-libstdc++"
|
|
+ AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
|
|
AC_LANG_PUSH(C++)
|
|
AC_LINK_IFELSE([
|
|
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
|
|
@@ -1625,7 +1625,7 @@ AC_ARG_WITH(stage1-ldflags,
|
|
# if supported. But if the user explicitly specified the libraries to use,
|
|
# trust that they are doing what they want.
|
|
if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
|
|
- stage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ stage1_ldflags="-static-libstdc++"
|
|
fi])
|
|
AC_SUBST(stage1_ldflags)
|
|
|
|
@@ -1654,7 +1654,7 @@ AC_ARG_WITH(boot-ldflags,
|
|
# statically. But if the user explicitly specified the libraries to
|
|
# use, trust that they are doing what they want.
|
|
if test "$poststage1_libs" = ""; then
|
|
- poststage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ poststage1_ldflags="-static-libstdc++"
|
|
fi])
|
|
AC_SUBST(poststage1_ldflags)
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -4998,14 +4998,14 @@ if test -z "$LD"; then
|
|
fi
|
|
fi
|
|
|
|
-# Check whether -static-libstdc++ -static-libgcc is supported.
|
|
+# Check whether -static-libstdc++ is supported.
|
|
have_static_libs=no
|
|
if test "$GCC" = yes; then
|
|
saved_LDFLAGS="$LDFLAGS"
|
|
|
|
- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++ -static-libgcc" >&5
|
|
-$as_echo_n "checking whether g++ accepts -static-libstdc++ -static-libgcc... " >&6; }
|
|
+ LDFLAGS="$LDFLAGS -static-libstdc++"
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++" >&5
|
|
+$as_echo_n "checking whether g++ accepts -static-libstdc++... " >&6; }
|
|
ac_ext=cpp
|
|
ac_cpp='$CXXCPP $CPPFLAGS'
|
|
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
|
@@ -5788,7 +5788,7 @@ else
|
|
# if supported. But if the user explicitly specified the libraries to use,
|
|
# trust that they are doing what they want.
|
|
if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
|
|
- stage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ stage1_ldflags="-static-libstdc++"
|
|
fi
|
|
fi
|
|
|
|
@@ -5824,7 +5824,7 @@ else
|
|
# statically. But if the user explicitly specified the libraries to
|
|
# use, trust that they are doing what they want.
|
|
if test "$poststage1_libs" = ""; then
|
|
- poststage1_ldflags="-static-libstdc++ -static-libgcc"
|
|
+ poststage1_ldflags="-static-libstdc++"
|
|
fi
|
|
fi
|
|
|