c6c731fe31
Add support for NXP layerscape ls1043ardb 64b/32b Dev board. LS1043a is an SoC with 4x64-bit up to 1.6 GHz ARMv8 A53 cores. ls1043ardb support features as: 2GB DDR4, 128MB NOR/512MB NAND, USB3.0, eSDHC, I2C, GPIO, PCIe/Mini-PCIe, 6x1G/1x10G network port, etc. 64b/32b ls1043ardb target is using 4.4 kernel, and rcw/u-boot/fman images from NXP QorIQ SDK release. All of 4.4 kernel patches porting from SDK release or upstream. QorIQ SDK ISOs can be downloaded from this location: http://www.nxp.com/products/software-and-tools/run-time-software/linux-sdk/linux-sdk-for-qoriq-processors:SDKLINUX Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
150 lines
4.6 KiB
Diff
150 lines
4.6 KiB
Diff
From 57d949256241fb79b669bbca0426c2d74a3dfc6e Mon Sep 17 00:00:00 2001
|
|
From: Shaohui Xie <Shaohui.Xie@freescale.com>
|
|
Date: Fri, 8 Jul 2016 10:27:39 +0800
|
|
Subject: [PATCH 02/70] dts/ls1043a: add LS1043ARDB board support
|
|
|
|
commit 9a6fce16a82d3412c9350b9f08eacebaa81c0a3d
|
|
[context adjustment]
|
|
|
|
Signed-off-by: Shaohui Xie <Shaohui.Xie@freescale.com>
|
|
Signed-off-by: Mingkai Hu <Mingkai.Hu@freescale.com>
|
|
Signed-off-by: Wenbin Song <Wenbin.Song@freescale.com>
|
|
Signed-off-by: Hou Zhiqiang <B48286@freescale.com>
|
|
Signed-off-by: Mingkai Hu <mingkai.hu@nxp.com>
|
|
Integrated-by: Zhao Qiang <qiang.zhao@nxp.com>
|
|
---
|
|
arch/arm64/boot/dts/freescale/Makefile | 1 +
|
|
arch/arm64/boot/dts/freescale/fsl-ls1043a-rdb.dts | 117 +++++++++++++++++++++
|
|
2 files changed, 118 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls1043a-rdb.dts
|
|
|
|
--- a/arch/arm64/boot/dts/freescale/Makefile
|
|
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
|
@@ -1,6 +1,7 @@
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2080a-qds.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2080a-rdb.dtb
|
|
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls2080a-simu.dtb
|
|
+dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1043a-rdb.dtb
|
|
|
|
always := $(dtb-y)
|
|
subdir-y := $(dts-dirs)
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1043a-rdb.dts
|
|
@@ -0,0 +1,117 @@
|
|
+/*
|
|
+ * Device Tree Include file for Freescale Layerscape-1043A family SoC.
|
|
+ *
|
|
+ * Copyright 2014-2015, Freescale Semiconductor
|
|
+ *
|
|
+ * Mingkai Hu <Mingkai.hu@freescale.com>
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPLv2 or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This library is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This library is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "fsl-ls1043a.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "LS1043A RDB Board";
|
|
+ compatible = "fsl,ls1043a-rdb", "fsl,ls1043a";
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ status = "okay";
|
|
+ ina220@40 {
|
|
+ compatible = "ti,ina220";
|
|
+ reg = <0x40>;
|
|
+ shunt-resistor = <1000>;
|
|
+ };
|
|
+ adt7461a@4c {
|
|
+ compatible = "adi,adt7461";
|
|
+ reg = <0x4c>;
|
|
+ };
|
|
+ eeprom@56 {
|
|
+ compatible = "at24,24c512";
|
|
+ reg = <0x52>;
|
|
+ };
|
|
+ eeprom@57 {
|
|
+ compatible = "at24,24c512";
|
|
+ reg = <0x53>;
|
|
+ };
|
|
+ rtc@68 {
|
|
+ compatible = "pericom,pt7c4338";
|
|
+ reg = <0x68>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ifc {
|
|
+ status = "okay";
|
|
+ #address-cells = <2>;
|
|
+ #size-cells = <1>;
|
|
+ /* NOR, NAND Flashes and FPGA on board */
|
|
+ ranges = <0x0 0x0 0x0 0x60000000 0x08000000
|
|
+ 0x1 0x0 0x0 0x7e800000 0x00010000
|
|
+ 0x2 0x0 0x0 0x7fb00000 0x00000100>;
|
|
+
|
|
+ nor@0,0 {
|
|
+ compatible = "cfi-flash";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ reg = <0x0 0x0 0x8000000>;
|
|
+ bank-width = <2>;
|
|
+ device-width = <1>;
|
|
+ };
|
|
+
|
|
+ nand@1,0 {
|
|
+ compatible = "fsl,ifc-nand";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ reg = <0x1 0x0 0x10000>;
|
|
+ };
|
|
+
|
|
+ cpld: board-control@2,0 {
|
|
+ compatible = "fsl,ls1043ardb-cpld";
|
|
+ reg = <0x2 0x0 0x0000100>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&duart0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&duart1 {
|
|
+ status = "okay";
|
|
+};
|