6926325829
Drop 302-fix_no_cmac_build.patch, it has been applied upstream. Security fixes: * (Severity: High) OCSP Status Request extension unbounded memory growth (CVE-2016-6304) * (Severity: Moderate) SSL_peek() hang on empty record (CVE-2016-6305) * 10 Low severity issues Security advisory: https://www.openssl.org/news/secadv/20160922.txt Changelog: https://www.openssl.org/news/cl102.txt Signed-off-by: Magnus Kroken <mkroken@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
58 lines
1.5 KiB
Diff
58 lines
1.5 KiB
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -139,7 +139,7 @@ FIPSCANLIB=
|
|
|
|
BASEADDR=0xFB00000
|
|
|
|
-DIRS= crypto ssl engines apps test tools
|
|
+DIRS= crypto ssl engines apps tools
|
|
ENGDIRS= ccgost
|
|
SHLIBDIRS= crypto ssl
|
|
|
|
@@ -157,7 +157,7 @@ SDIRS= \
|
|
|
|
# tests to perform. "alltests" is a special word indicating that all tests
|
|
# should be performed.
|
|
-TESTS = alltests
|
|
+TESTS =
|
|
|
|
MAKEFILE= Makefile
|
|
|
|
@@ -171,7 +171,7 @@ SHELL=/bin/sh
|
|
|
|
TOP= .
|
|
ONEDIRS=out tmp
|
|
-EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
+EDIRS= times bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
WDIRS= windows
|
|
LIBS= libcrypto.a libssl.a
|
|
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
|
|
@@ -275,7 +275,7 @@ reflect:
|
|
|
|
sub_all: build_all
|
|
|
|
-build_all: build_libs build_apps build_tests build_tools
|
|
+build_all: build_libs build_apps build_tools
|
|
|
|
build_libs: build_libcrypto build_libssl openssl.pc
|
|
|
|
@@ -533,7 +533,7 @@ dist:
|
|
@$(MAKE) SDIRS='$(SDIRS)' clean
|
|
@$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar
|
|
|
|
-install: all install_docs install_sw
|
|
+install: all install_sw
|
|
|
|
install_sw:
|
|
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|
|
--- a/Makefile.org
|
|
+++ b/Makefile.org
|
|
@@ -531,7 +531,7 @@ dist:
|
|
@$(MAKE) SDIRS='$(SDIRS)' clean
|
|
@$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar
|
|
|
|
-install: all install_docs install_sw
|
|
+install: all install_sw
|
|
|
|
install_sw:
|
|
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|