13639e76dd
Do not leak the user space CFLAGS into the kernel space any more, this allows us to activate the MIPS16 build. This decreases the size of the ipk file from 87589 bytes to 81267 bytes. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
21 lines
1 KiB
Diff
21 lines
1 KiB
Diff
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -213,8 +213,7 @@ drv_mei_cpe_common_cflags = $(AM_CFLAGS)
|
|
else
|
|
|
|
drv_mei_cpe_common_cflags = \
|
|
- $(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
|
|
- -pipe -Wimplicit -Wunused -Wuninitialized -Wsign-compare -Wstrict-aliasing
|
|
+ -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB
|
|
|
|
endif
|
|
|
|
@@ -354,7 +353,7 @@ drv_mei_cpe.ko: $(drv_mei_cpe_SOURCES)
|
|
@echo -e "# drv_mei_cpe: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
|
@echo -e "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
|
@echo -e "$(subst .ko,,$@)-y := $(drv_mei_cpe_OBJS)" >> $(PWD)/Kbuild
|
|
- @echo -e "EXTRA_CFLAGS := $(CFLAGS) $(drv_mei_cpe_CFLAGS) -I@abs_srcdir@ -I@abs_srcdir@/auto_header $(IFXOS_INCLUDE_PATH)" >> $(PWD)/Kbuild
|
|
+ @echo -e "EXTRA_CFLAGS := $(drv_mei_cpe_CFLAGS) -I@abs_srcdir@ -I@abs_srcdir@/auto_header $(IFXOS_INCLUDE_PATH)" >> $(PWD)/Kbuild
|
|
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
|
|
|
clean-generic:
|