7bbf4117c6
This add support for kernel 4.9 to the ar71xx target. It was compile tested with the generic, NAND and mikrotik subtarget. Multiple members of the community tested it on their boards and did not report any major problem so far. Especially the NAND part received some changes to adapt to the new kernel APIs. The serial driver hack used for the Arduino Yun was not ported because the kernel changed there a lot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
24 lines
814 B
Diff
24 lines
814 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -768,6 +768,11 @@ config SPI_RB4XX_CPLD
|
|
SPI driver for the Xilinx CPLD chip present on the
|
|
MikroTik RB4xx boards.
|
|
|
|
+config SPI_VSC7385
|
|
+ tristate "Vitesse VSC7385 ethernet switch driver"
|
|
+ help
|
|
+ SPI driver for the Vitesse VSC7385 ethernet switch.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -99,6 +99,7 @@ spi-thunderx-objs := spi-cavium.o spi-
|
|
obj-$(CONFIG_SPI_THUNDERX) += spi-thunderx.o
|
|
obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
|
|
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
|
|
+obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
|
|
obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
|
|
obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
|
|
obj-$(CONFIG_SPI_XLP) += spi-xlp.o
|