openwrtv4/target/linux/generic-2.4/patches/010-disable_old_squashfs_compatibility.patch
Andy Boyett 88e632d853 generic-2.4: refresh patches
SVN-Revision: 15860
2009-05-15 10:36:04 +00:00

23 lines
562 B
Diff

--- a/fs/squashfs/Makefile
+++ b/fs/squashfs/Makefile
@@ -4,7 +4,7 @@
O_TARGET := squashfs.o
-obj-y := inode.o squashfs2_0.o LzmaDecode.o
+obj-y := inode.o LzmaDecode.o
obj-m := $(O_TARGET)
--- a/fs/squashfs/squashfs.h
+++ b/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
#else