969ec949a8
This fixes the following security problems: CVE-2016-0754: remote file name path traversal in curl tool for Windows http://curl.haxx.se/docs/adv_20160127A.html CVE-2016-0755: NTLM credentials not-checked for proxy connection re-use http://curl.haxx.se/docs/adv_20160127B.html Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 48614
22 lines
695 B
Diff
22 lines
695 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -141,7 +141,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
bin_SCRIPTS = curl-config
|
|
|
|
SUBDIRS = lib src include scripts
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -601,7 +601,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
|
|
|
|
bin_SCRIPTS = curl-config
|
|
SUBDIRS = lib src include scripts
|
|
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
|
|
+DIST_SUBDIRS = $(SUBDIRS) packages
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
pkgconfig_DATA = libcurl.pc
|
|
LIB_VTLS_CFILES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c \
|