openwrtv4/target/linux/adm5120/patches-2.6.23/103-mtd_trxsplit.patch
Gabor Juhos 32f2870131 refresh .23 kernel paches
SVN-Revision: 10366
2008-02-03 05:15:25 +00:00

28 lines
1,006 B
Diff

Index: linux-2.6.23.14/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.23.14.orig/drivers/mtd/Kconfig
+++ linux-2.6.23.14/drivers/mtd/Kconfig
@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
depends on MTD_PARTITIONS
default y
+config MTD_TRXSPLIT
+ bool "Automatically find and split TRX partitions"
+ depends on MTD_PARTITIONS
+ default n
+
config MTD_REDBOOT_PARTS
tristate "RedBoot partition table parsing"
depends on MTD_PARTITIONS
Index: linux-2.6.23.14/drivers/mtd/Makefile
===================================================================
--- linux-2.6.23.14.orig/drivers/mtd/Makefile
+++ linux-2.6.23.14/drivers/mtd/Makefile
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o