76d079204d
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
22 lines
741 B
Diff
22 lines
741 B
Diff
--- a/drivers/pci/host/Kconfig
|
|
+++ b/drivers/pci/host/Kconfig
|
|
@@ -91,4 +91,9 @@ config PCI_XGENE
|
|
There are 5 internal PCIe ports available. Each port is GEN3 capable
|
|
and have varied lanes from x1 to x8.
|
|
|
|
+config PCI_OXNAS
|
|
+ bool "PLX Oxnas PCIe controller"
|
|
+ depends on ARCH_OXNAS
|
|
+ select PCIEPORTBUS
|
|
+
|
|
endmenu
|
|
--- a/drivers/pci/host/Makefile
|
|
+++ b/drivers/pci/host/Makefile
|
|
@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
|
|
obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
|
|
obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
|
|
obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
|
|
+obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
|
|
obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
|
|
obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
|
|
obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o
|