011f2c26f1
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
25 lines
812 B
Diff
25 lines
812 B
Diff
From 49b92b33aa6681e75f579b7369f34a53e9376e6c Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Sat, 26 Nov 2016 14:01:52 +0000
|
|
Subject: [PATCH] ARM: dts: Restore dtbs_install functionality
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -806,10 +806,11 @@ dtstree := $(srctree)/$(src)
|
|
dtb-$(CONFIG_OF_ALL_DTBS) := $(patsubst $(dtstree)/%.dts,%.dtb, $(wildcard $(dtstree)/*.dts))
|
|
|
|
always := $(dtb-y)
|
|
-subdir-y := $(dts-dirs) overlays
|
|
+subdir-y := overlays
|
|
clean-files := *.dtb
|
|
|
|
# Enable fixups to support overlays on BCM2708 platforms
|
|
ifeq ($(RPI_DT_OVERLAYS),y)
|
|
DTC_FLAGS ?= -@ -H epapr
|
|
+ dts-dirs += overlays
|
|
endif
|