8e9eed3442
iproute2-4.0 had connmark support added by nbd. This does not work with 4.x kernels. iproute2-4.3 is the latest version and has his changes mainlined. This patch updates the package to iproute2-4.3 and fixes the patches so that it compiles. This should resolve ticket #21374. Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net> SVN-Revision: 48098
10 lines
391 B
Diff
10 lines
391 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -34,7 +34,7 @@ ADDLIB+=ipx_ntop.o ipx_pton.o
|
|
DEFINES += -D_GNU_SOURCE
|
|
# Turn on transparent support for LFS
|
|
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
-CCOPTS = -O2
|
|
+CCOPTS = -O2 $(EXTRA_CCOPTS)
|
|
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
|
|
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
|