4f9fcd94bd
This fix contains 2 parts: - kernel 4.1: backport upstream patch "perf build: Do not fail on missing Build file" - add NO_LZMA=1 to perf MAKE_FLAGS to disable LZMA support Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> SVN-Revision: 47338
67 lines
2.1 KiB
Diff
67 lines
2.1 KiB
Diff
From d7a3d85e08477a979933a2bb3b525a8de99543c2 Mon Sep 17 00:00:00 2001
|
|
From: Jiri Olsa <jolsa@kernel.org>
|
|
Date: Fri, 29 May 2015 17:42:58 +0200
|
|
Subject: [PATCH] perf build: Do not fail on missing Build file
|
|
|
|
Allow nesting into directories without Build file. Currently we force
|
|
include of the Build file, which fails the build when the Build file is
|
|
missing.
|
|
|
|
We already support empty *-in.o' objects if there's nothing in the
|
|
directory to be compiled, so we can just use it for missing Build file
|
|
cases.
|
|
|
|
Also adding this case under tests.
|
|
|
|
Reported-by: Rabin Vincent <rabin.vincent@axis.com>
|
|
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
|
|
Cc: David Ahern <dsahern@gmail.com>
|
|
Cc: Namhyung Kim <namhyung@kernel.org>
|
|
Cc: Paul Mackerras <paulus@samba.org>
|
|
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
|
|
Cc: Rabin Vincent <rabin.vincent@axis.com>
|
|
Link: http://lkml.kernel.org/r/1432914178-24086-1-git-send-email-jolsa@kernel.org
|
|
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
|
|
---
|
|
tools/build/Makefile.build | 2 +-
|
|
tools/build/tests/ex/Build | 1 +
|
|
tools/build/tests/ex/empty2/README | 2 ++
|
|
3 files changed, 4 insertions(+), 1 deletion(-)
|
|
create mode 100644 tools/build/tests/ex/empty2/README
|
|
|
|
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
|
|
index 10df572..69c35cf 100644
|
|
--- a/tools/build/Makefile.build
|
|
+++ b/tools/build/Makefile.build
|
|
@@ -37,7 +37,7 @@ subdir-obj-y :=
|
|
|
|
# Build definitions
|
|
build-file := $(dir)/Build
|
|
-include $(build-file)
|
|
+-include $(build-file)
|
|
|
|
quiet_cmd_flex = FLEX $@
|
|
quiet_cmd_bison = BISON $@
|
|
diff --git a/tools/build/tests/ex/Build b/tools/build/tests/ex/Build
|
|
index 0e6c3e6..70d8762 100644
|
|
--- a/tools/build/tests/ex/Build
|
|
+++ b/tools/build/tests/ex/Build
|
|
@@ -2,6 +2,7 @@ ex-y += ex.o
|
|
ex-y += a.o
|
|
ex-y += b.o
|
|
ex-y += empty/
|
|
+ex-y += empty2/
|
|
|
|
libex-y += c.o
|
|
libex-y += d.o
|
|
diff --git a/tools/build/tests/ex/empty2/README b/tools/build/tests/ex/empty2/README
|
|
new file mode 100644
|
|
index 0000000..2107cc5
|
|
--- /dev/null
|
|
+++ b/tools/build/tests/ex/empty2/README
|
|
@@ -0,0 +1,2 @@
|
|
+This directory is left intentionally without Build file
|
|
+to test proper nesting into Build-less directories.
|
|
--
|
|
2.1.4
|
|
|