b3f95490b9
This adds initial support for kernel 4.14 based on the patches for kernel 4.9. In the configuration I deactivated some of the new possible security features like: CONFIG_REFCOUNT_FULL CONFIG_SLAB_FREELIST_HARDENED CONFIG_SOFTLOCKUP_DETECTOR CONFIG_WARN_ALL_UNSEEDED_RANDOM And these overlay FS options are also deactivated: CONFIG_OVERLAY_FS_INDEX CONFIG_OVERLAY_FS_REDIRECT_DIR I activated this: CONFIG_FORTIFY_SOURCE CONFIG_POSIX_TIMERS CONFIG_SLAB_MERGE_DEFAULT CONFIG_WATCHDOG_HANDLE_BOOT_ENABLED I am not sure if I did the porting correct for the following patches: target/linux/generic/backport-4.14/020-backport_netfilter_rtcache.patch target/linux/generic/hack-4.14/220-gc_sections.patch target/linux/generic/hack-4.14/321-powerpc_crtsavres_prereq.patch target/linux/generic/pending-4.14/305-mips_module_reloc.patch target/linux/generic/pending-4.14/611-netfilter_match_bypass_default_table.patch target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
32 lines
903 B
Diff
32 lines
903 B
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: [PATCH] kernel/3.10: move squashfs check from rootfs split code into a separate file
|
|
|
|
lede-commit: d89bea92b31b4e157a0fa438e75370f089f73427
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
drivers/mtd/Kconfig | 2 ++
|
|
drivers/mtd/Makefile | 2 ++
|
|
2 files changed, 4 insertions(+)
|
|
|
|
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
|
|
depends on MTD_SPLIT_FIRMWARE
|
|
default "firmware"
|
|
|
|
+source "drivers/mtd/mtdsplit/Kconfig"
|
|
+
|
|
endmenu
|
|
|
|
config MTD_TESTS
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -7,6 +7,8 @@
|
|
obj-$(CONFIG_MTD) += mtd.o
|
|
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
|
|
|
+obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
|
|
+
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|